Support » Plugin: WordPress File Upload » Upload Path

  • No matter how I modify the control pannel setting, I am unable to set the upload path in the settings. No matter how I specify a directory in Base Directory, or what setting I choose in Admin Domain. All uploads ended up in /wp-content.

    I was able to set the path in the shortcode settings for the individual instances, but that seems not ideal.

    And yes, the WP Install is not at the root level, but in it’s own directory. But the Site and WP address DO currently match.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 16 through 22 (of 22 total)
  • pikkabbu

    (@pikkabbu)

    Hello,

    I have the same issue. No way to set a specific upload path. Neither in the setting page, nor with the shortcode.

    I’m interested by the pro version, to set a member’s gallery, but I need to check everything works fine with the free (demo) version.

    We are several users with the same issue, assuming that others people don’t care where files are upload. I respectfully suggest that the author should have a closer look to this part of the plugin by his end.

    Michel

    pikkabbu

    (@pikkabbu)

    I’m back with some apologizes. It works fine within the sortcode, but you must be quite aware of this topic from user’s guide:

    “This is the path of the upload directory. The path must be relative to wp-content folder of your WordPress website. For instance, if your upload directory is “wp-content/uploads/myuploaddir”, then uploadpath must have the value “uploads/myuploaddir”. The default value is “uploads”, meaning that the files will be uploaded to wp-content/uploads dir.”

    So, [wordpress_file_upload uploadpath="uploads/myfolder/"] works fine

    Plugin Author nickboss

    (@nickboss)

    Hi, you have a point, maybe I need to define it in an easier way.

    Nickolas

    Hi there, I’m trying to specify my upload directory too without luck.

    Initially everything would land in /uploads/ even if I specified my upload path to be uploads/unique-directory/. I experimented with uploading files to Media (and attaching uploaded files to post) but now everything lands in my media folders even with those switches off. I don’t want files uploaded through this portal to get mixed up with my site files.

    Please can you explain how this works? Thanks in advance =)

    Plugin Author nickboss

    (@nickboss)

    Hi, if you enable “Add Uploaded Files to Media” then the plugin will force the files to be saved in the default upload folder of WordPress, regardless of Upload Path setting.

    If you do not use this setting, then Upload Path should work. So, if you set it to uploads/unique-directory/ then files should go to /wp-content/uploads/unique-directory. Does this folder exist?

    Regards

    Nickolas

    Hello and thank so much for your prompt reply – I wish I saw it before now…

    As you have just stated is how I would expect it to work =) However, when turning off “Add files to media” they keep writing to media – the switch doesn’t turn it off. I experimented with having that feature on to see what suited my project best – I would prefer the files be written to uploads/unique-directory/ but prior to the above Media problem it would only save to /uploads/ even while this folder exists.

    Thanks for looking at this!

    Plugin Author nickboss

    (@nickboss)

    Do you have “Attach Uploaded Files to Post” option active maybe?

    Can you send me your shortcode to check?

    Nickolas

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Upload Path’ is closed to new replies.