• I only have two designated roles for my site: admin and author.

    No problem with the admin role as far as uploading messages. However, this is what I’ve found under the author role:

    – When using the WPUF form, I am NOT able to upload images. I get this error message: An error occurred in the upload. Please try again later.

    – However, when I do the upload from the backend (ie not using the WPUF form) it works just fine.

    I checked the user capabilities for author and “upload files” is definitely included. So it appears that WPUF does not carry over the capability for uploading images granted in the backend.

    How do i fix this?


Viewing 5 replies - 1 through 5 (of 5 total)
  • BTW, just need to add: the featured image upload works just fine from the frontend on author role.

    I’m having exactly the same error now on any user level below Admin.

    Have tried disabling all other plugins and even with only this plugin enabled it still does not work.

    I haven’t figured this out* but I suspect this is to do with the settings being on Admin-only for accessing the backend.

    * I decided to upgrade to the PRO version where uploading for < Admin role works. Unfortunately, it doesn’t look like it’s possible to create a gallery with PRO, but that’s another story.

    This is a well known WordPress 3.5.1 problem.

    Either upgrade to Pro or the fork to fix

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Upload only works for Admin role’ is closed to new replies.