Support » Networking WordPress » Upload of theme in multisite results in error

  • Resolved dcurran


    I am running a multisite install of WordPress here: When I try to upload a new theme zip file via: network admin>themes>add new>upload I get the following error:
    “The uploaded file could not be moved to /home/gcevoice/public_html/wp-content/uploads/2012/09.”

    I believe this was previously working and I’m not sure when or why it stopped. It seems that this path is not correct but I’m not sure where/how to change it. Images when upload work correctly. Please help direct me to what’s wrong.

    my .htaccess file is:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

Viewing 8 replies - 1 through 8 (of 8 total)
  • “The uploaded file could not be moved to /home/gcevoice/public_html/wp-content/uploads/2012/09.”

    Why is it trying to up to uploads?

    What happens if you try to install themes via the normal theme navigator? The one that searches

    Thanks for your reply. When I try to install a theme from the theme navigator it works just fine. It also works if I upload it via FTP to the themes folder. It seems just the theme up-loader is not functioning correctly.

    Two thoughts.

    1) YOu’re trying to upload too large a file.
    2) Uploading zips isn’t allowed.

    To test, let’s do somethign silly!

    Go to the media uploader and upload the theme as a zip there. Yes, I know it’s wrong 😉 But we’re testing something!

    I think you may be on to something here. When I try to upload the zip to the media uploader I get the error: “Maximum upload file size: 2MB “” has failed to upload due to an error. This file exceeds the maximum upload size for this site.”

    In an effort to fix this I changed the max upload file size to 6144kb (6mb). Which gave me the same error so I also made this change in the php.ini file: “; Maximum allowed size for uploaded files.
    upload_max_filesize = 6M”

    The theme zip is only 2.4mb, but I am continuing to get the same error. Can you tell me what I should do to fix this?

    Thanks so so much!

    Go to wp-admin/network/settings.php

    Scroll down to Max upload file size. What’s that?

    Thanks for the quick response. wp-admin/network/settings.php is where I changed it to: 6144KB

    Okay, it’s probably something on your server. Ask your webhost how to bump the PHP upload limit.

    I contacted my host and they had to up it for me. Now everything appears to be working. Thanks so much for all of your help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Upload of theme in multisite results in error’ is closed to new replies.