WordPress.org

Support

Support » How-To and Troubleshooting » Upload new media: Unable to create directory

Upload new media: Unable to create directory

  • I’m getting this error:

    Unable to create directory /home/xxx/public_html/wp-content/uploads/2009/07. Is its parent directory writable by the server?

    I know this is not something new but I’ve tried a few things and they still don’t work:

    • set the directory permissions to 777 for wp-content/uploads
    • set “Store uploads in this folder” to wp-content/uploads
    • left “Full URL path to files” blank
    • tried unchecking “Organize my uploads into month- and year-based folders”
    • it was working fine before we changed the domain name to the production domain name. what could be wrong?

Viewing 15 replies - 1 through 15 (of 25 total)
  • Give “recursive” 777 permission to uploads folder. Ask your Host to do this from Shell access:

    chmod -R 777 wp-contents/uploads

    Thanks for the advice but it has been set to recursive. I’ve used Firezilla FTP client to perform that and have double-check with my service provider. Is there some backend config files that I can go check?

    Hi,

    From the provided error message…it shows that there is a permissions issue with folder..assign 766 recursive permissions to wp-contents folder..

    Also check the path wordpress admin area -> settings -> miscellaneous settings > it should be: wp-contents/uploads rather than wp-contents/uploads/ [do not require back slash at end of the path]

    Thanks,

    Shane G.

    is it possible to create the image folder through an external script and upload an image through an image url?

    Hi Shane,

    I’ve set the folder to 777 recursive and ensured that wp-content/uploads under Settings > Miscellaneous do not have a “/” behind.

    what else could be the problem?

    thanks,
    Simon

    Having the exact same problem – using 2.8.1 – permissions set at 766 (tried all sorts of variants). WordPress will not create the uploads folder.

    apart from the permission issue and Ownership of the files (I am sure this is not the issue, because you can access ftp), there is no reason to receive this error. However, just consult your host once and see what is their opinion.

    I had the same problem. What solved it for me was changing the “Store uploads in this folder” setting (in Settings->Miscellaneous) from “/wp-content/uploads” to “wp-content/uploads”.

    vilimaunula … you ROCK! tried every other suggestion for this problem, but yours worked! Thanks 🙂

    OK – this is what worked for me. Set blog directory to 775, set WP_Content to 775, set uploads to 777. On Settings/Miscellaneous lose the / in front of wp-content/uploads AND click OFF organize by date AND track links

    Finally! Took 2 weeks of all sorts of research and combinations.

    Thank you wright21 , this works for me too

    If you tryed everything and upload in your wordpress still doesn’t work – i have an answer for you. In short: php safe mode won’t let you create files or directories if your php scripts and upload directory belongs to different users. So there are 2 possible solutions: either disable php safemode (not recommended), or change an owner of scripts and upload directory:

    cd blog_root
    chown -R apache:apache *

    Complete description available here: http://tamkovich.com/2009/09/unable-to-create-directory-wp-content-uploads-is-its-parent-directory-writable-by-the-server/ (in Russian)

    Thank you ‘Wright21’, solution also effective for myself.

    Cheers!

    hey guys, my problem was that the uploader worked, but the thumbnail and directory weren’t being created (I had no error messages, just no image) I found a very simple solution,

    settings -> misc

    make sure upload location = wp-content/uploads

    mine was /wp-content/uploads and on another there was a huge string that got inserted so just double check. Make sure there is NO ” / ” at beginning or end of location

    Works fine.

    thank you, wright21
    it works to me too.
    cheers

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Upload new media: Unable to create directory’ is closed to new replies.
Skip to toolbar