Support » Fixing WordPress » Upload New Media – Select Files button – Not Working

  • Resolved scottmee

    (@scottmee)


    Hi,

    Noticed a problem on alot of wordpress installs on Chrome using 4.7.3

    The Upload New Media – Select Files button will not work at all.

    I tried turning all plugins off, using Twenty Sixteen/Seventeen theme and the same problem.

    I have noticed googling that this seems to be a common issue currently, is there a current fix as its effecting alot of my websites.

Viewing 15 replies - 1 through 15 (of 31 total)
  • Moderator James Huff

    (@macmanx)

    Halfelf Minion ๐Ÿš€

    Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file just below the define('DB_HOST' line.

    To do so, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and edit the file with a plain text editor.

    https://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation

    Ekans

    (@ekans)

    Hi there,

    I also have this problem. This issue only happens with Chrome (56.0.2924.87 (64-bit)).
    I already added the line on wp-config.php, but didn’t solved anything.

    Do you have any other suggestions?

    Regards

    rusidol

    (@rusidol)

    Same here, Chrome v.57.0.2987.98. I CAN drag&drop files to the control but “Select Files” doesn’t work.

    • Tried on old and fresh WP installations
    • It has nothing todo with installed plugins or theme options
    • It works fine in IE10 and FireFox, and my work PC
    perfectbrilliant

    (@perfectbrilliant)

    I am also having this same problem with Chrome. Works with Microsoft Edge.

    Jupiter_Dev

    (@jupiter_dev)

    Been having this problem for about a week on 2 sites. Different servers. Tired James Huff’s solution, but it didn’t work for me. Tried several themes, disabling all plugins, replacing /wp-includes/js, max memory limit set to 64MB.

    Jupiter_Dev

    (@jupiter_dev)

    The strangest thing is one site was recently moved to production from development. The development site does not have the issue, but the production site does. these two have the same server specs and php configuration. The second site with the issue was developed in place. There is no js error in the console, and the drag and drop feature works. “select Files” does nothing. I hope these details help to get this sorted out.

    Howie

    (@dotlicious)

    Confirmed Chrome v57.0.2987.110 – โ€œselect Filesโ€ does nothing

    IE / Edge / Firefox all fine.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion ๐Ÿš€

    I’m not having this problem myself in Chrome 57.0.2987.98, so let’s rule-out some other elements.

    First, please make sure that Chrome is up to date by visiting https://whatbrowser.org/

    If it is not, please try updating.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions temporarily disabled.

    Cliff

    (@heathcliffe2000)

    I also have this problem.

    It is only with Chrome (I only have 64 bit)57.0.2987.110

    Tried on two different PC’s, after clearing cache, cookies and even resetting chrome, running incognito etc.

    It is ONLY an issue when mode=grid (i.e. using the grid view instead of list) and you use the Add New button at the top of the view (Next to Media Library)

    If you use the list view, the button works as expected.
    If you use the Add New on the menu on the left, it seems to work whichever view you have open.

    Hope that helps.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion ๐Ÿš€

    Any errors in the JavaScript console when you load the page or try to use the button?

    https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Cliff

    (@heathcliffe2000)

    No none.

    The element is:

    <a href="#" class="browser button button-hero" id="__wp-uploader-id-1" style="display: inline; position: relative; z-index: 1;">Select Files</a>

    The element on the list button is:
    <input id="plupload-browse-button" type="button" value="Select Files" class="button" style="position: relative; z-index: 1;">

    I have no idea about coding, but thought that might help ๐Ÿ™‚

    • This reply was modified 7 months ago by  Cliff.
    • This reply was modified 7 months ago by  Cliff.
    Moderator James Huff

    (@macmanx)

    Halfelf Minion ๐Ÿš€

    That’s what it should be.

    Chrome just sent out an update: 57.0.2987.110. It’s still working for me, though it was working for me before anyway.

    Any luck after an update?

    If not, maybe someone else has something in their JavaScript console.

    Also, when you check with all extensions disabled, please make sure it’s *all* extensions. We have seen ad blockers break buttons before.

    Ekans

    (@ekans)

    Hi James,

    I already:

    – Updated chrome to latest version;
    – Disabled ALL extensions;
    – Cleaned browserโ€™s cache and cookies.

    But the problem still maintains.

    I also tested what Cliff said, and if its in grid view, don’t work, but if is in list view, work well.

    Regards

    Cliff

    (@heathcliffe2000)

    Yes James,
    You will see from my comment that I am already on 110.
    All extensions disabled, incognito window, etc etc.
    I had my hosting company take a look, and they were able to re-create the issue too.
    Why doesn’t WP use the same code for both buttons?

    Moderator James Huff

    (@macmanx)

    Halfelf Minion ๐Ÿš€

    The list view was the oldest style, since the beginning. Comparatively, the grid view is relatively new. So, I imagine it’s different because of new/updated functionality.

    I’m still struggling to reproduce the issue myself, across 5 sites on different hosts with different themes/plugins. Maybe because I’m on a Mac and the Mac version of Chrome isn’t affected?

    Are either of you on a Mac, or are you all on Windows?

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Upload New Media – Select Files button – Not Working’ is closed to new replies.