Support » Fixing WordPress » Upload new media crashing browser

  • If I start a new page and upload media files (mp3, jpg, etc…) I have no problems. The flash uploader works like a charm.

    But if I go to the media/add new media and try to upload any kind of file, it does nothing for a minute and then crashes Firefox. I’ve tried it in Safari and does the same thing. I tried using the browser uploader instead of the Flash, one and while it doesn’t crash my browser, it doesn’t do anything at all 🙂

    Any help would be appreciated:

    Flash 10, FireFox 3.0.6, and WP 2.7

    Kinda funky.

    Thanks for your help

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’m having a similar problem. If I click any of the uploader buttons, it starts to bring up the uploader screen, and then Firefox crashes. I can upload via FTP, insert manually, and then bring up the size/layout screen to adjust things. It just started happening yesterday and I can’t come up with anything I did to cause it.

    Something that could potentially help whoever might be looking into this — I seem to be having this problem on multiple WordPress installations that are on different servers. Also, the problem is happening on multiple *computers*, as I’ve had the crash happen on my office and living room computers. The computers are on the same network, but I doubt that’s the issue. It seems to be some way that WP is interacting with Firefox.

    Interestingly, the uploader appears to work in IE7. I can use that as a workaround if necessary, but it’s a pain in the rear.

    This doesn’t appear to be a plugin issue with me, by the way. I disabled all plugins in one of my WP installations and it still crashed. I also have closed browsers, deleted histories, and restarted computers … no luck.

    Pardon the “me too” post, but I’m having the same problem that endgamepr is describing. My install of WordPress, running on Byethost’s free server has never given me any problems until I tried to insert an image today. The upload box frame appears, but Firefox crashes before anything shows up in it.

    This is indeed strange. What could cause this? And more importantly, how can I fix it?

    And similarly to endgamepr’s situation, the feature works fine in Opera. I noticed the sticky post and looked it over, but none of the things mentioned there seem to apply. My install was working in Firefox and then it stopped.

    SOLVED – for me anyway. I disabled the Google Gears Firefox add-on. Not just for my WordPress site – I had to disable the add-on entirely.

    The bizarre thing is that I installed that add-on a while back and it didn’t affect anything; the upload/insert function continued to work until this morning. Then it crashed every time I tried to use it. Until I disabled Gears.

    Buh-bye Gears.

    Disabling Gears seems to have solved it for me too. Thanks, Teratoma! Very strange on my part as well. I’ve had Gears installed for a long time, but this problem just cropped up yesterday. I wonder if Google updated the plugin? I would think I would be notified of that, though. Or, rather, I would *hope* I’d be notified…


    You can also add this code in htaccess file and have a check with the uplloading service:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    [spam link removed]

    I came to the forums to search for a solution to this problem. Thanks for letting us know about Gears. I disabled it and now I can work with the image uploader without crashing Firefox.

    I didn’t even know I had Gears. Not even sure what it is… 🙂

    I imagine gears works with something on Google’s server side, so they probably made the changes that affected WordPress there, and not within the add-on itself. I’m just speculating though.

    Good theory Teratoma.

    I had the same problem tonight and thanks to this thread, disabled the Google Gears plugin, but that didn’t totally fix the problem because I was using “Turbo” on my site. I had to reinstall fresh versions of wp-admin/gears-manifest.php wp-admin/tools.php Restart Firefox, log back into my site and it seems to work fine now.

    I hate stupid problems like this that crop up out of nowhere. I don’t have time to figure out how to fix all these stupid bugs!!!

    Hmm, unless I was just being slack with updating my browser, I thought that the crashing (which is happening with me to – solved by using IE to upload the photos – ick!) was due to the newer update of Firefox? or am I dreaming?! It worked before in Firefox pre-update…

    First, I gotta say, this community rocks! I spent hours trying to chase this problem down before finding the solution here. Now I know better. Look here first!

    My Firefox was crashing as soon as I clicked any of the media upload buttons. I found a “$ is not a function” entry in the error log, and that started my wild goose chase.

    But, after disabling, then uninstalling Google Gears, then restarting Firefox, everything is back to normal. Personally, I don’t even remember downloading, installing, or enabling Gears, but I think it’s pretty bogus that something like that can cause such ill side-effects. Introducing bad code to a stable environment is worse than bringing warm, flat beer to a cookout, especially if you’re crashing the joint…


    thanks so much for this solution . . . i simply disabled Gears for my WordPress site and all was well again with the image insert/upload.

    Did this issue actually get corrected? The reason I ask is that after updating to WordPress 2.8, I decided to re-enable Gears for my site. Then I created a new post and uploaded a pic with no problems. I then closed Firefox, re-opened it and edited the post, uploading another pic. Everything worked.

    Now of course the original issue was that it worked fine for a while, then one day we all woke up one morning and our blawgz was all broken. Is this going to happen again?

    I’m going to leave mine enabled – the thing is I have noticed an improvement in speed – so I’ll keep you updated.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Upload new media crashing browser’ is closed to new replies.