Support » Theme: Customizr » upload logo button broken, can i circumvent? or how to fix?

  • site:

    i am running a child theme and i used the front end of the customizr interface to upload a logo. i subsequently removed it, and when i tried to re-up, it does nothing now. well, i take it back…. the button does pull up the file select window, but when i select the appropriate file it does not upload, it does not make reference to the file in the code, it does not change the status of the “save and publish” button. it’s just broken.

    also, incidentally, the favicon stopped showing up too. it still has the “remove” link next to the upload button, so iassume it still believes it has a valid value its using. why?

    so my question is how do i load an image into the logo spot without using the front end uploader?

    other pertainant facts:

    i was attempting to put a picture in there by other means (probably rather misguidedly, my coding is okay, but not so great). i wanted to display images underneath the logo, and got that to work using the .brand div, and wanted to put a y-repeating image overlayed onto the body, but never could figure that out because i’m already using the body background to load up a repeating 10 x 10px box of a non web color that is essential to the aesthetics of the site.

    this is what i tried to use, but i think it’s dependent on the image actually being there because it defaults to the site title as a link in liu of the image:

    .brand h1{
    background: url(;
    background-repeat: repeat-y;
    padding-top: 0px;
    padding-bottom: 0px;

    this part worked flawlessly to put the background i needed behind the logo. however now that i can’t upload, i tried this:

    .tc-header .brand{
    background-image: url(;
    background-repeat: no-repeat;

    which kinda works but doesn’t align properly, and if i mess with the padding on the second one, it messes up the first one too.

    so, these are two separate elements being stacked.

    any other needed information can be provided. or, again, see for yourself at

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,
    1) check the file permissions of the wp-content folder on your server : you need to be able to read / write at least
    2) check if there are plugin in conflict with the theme : just disable them to see if the bug persists
    Hope this helps

    yes, i checked the permissions before i submitted here, and have subsequently had some other issues and disabled the plugins them my child theme, then customizr itself and got everything squared away. it turns out the problem described above with the uploader is because my server insists on secure communication (by design, because of the nature of the site, to be HIPAA compliant).

    any pointers on how to get wordpress to communicate through FTPS?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘upload logo button broken, can i circumvent? or how to fix?’ is closed to new replies.