Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Upload Images Get File Permission Error

  • Resolved GCinAZ

    (@gcorrick)


    After updating to WordPress 5.0 I can no long upload images to any gallery. I get the error Could not write to file. Please check filesystem permissions. Filename: /home/saddle20/public_html/wp-content/gallery/test/image.jpg”.

    I also get this error if I try to import an image to a gallery from my Media Library. I have no problems uploading images to my Media Library, but can’t import them to any NextGen Gallery.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Thread Starter GCinAZ

    (@gcorrick)

    I should add that all file permissions on my server have not changed

    Same issue to me. I can use the Media Library without any problems.
    But not the gallery ddirectory anymore.

    Using local development pc with Win 10-pro, ntfs & WordPress 5.01.

    And, yes, I granted all permissions in the hole gallery directory to me/my user account.
    But error still remains.

    Please help.

    Same here. With 4.9.9. I want to try workarround “A variable mismatch has been detected” after detect new images in folder (uploaded via FTP), my second try: delete the images via FTP und try upload via upload image to gallery -> File Permission Error

    I’m getting the same problem. I updated NextGen and it was broken. I realized afterward that WordPress needed an update, but that didn’t fix it either. I have no idea what to do :/

    Could not write to file. Please check filesystem permissions. Filename: /hermes/bosnaweb17a/b1151/ipw.cryotank/steam/wp-content/gallery/trine2/Trine-2-01-HD.png

    Plugin Author Imagely

    (@imagely)

    Hi @gcorrick!

    First, let’s check if is an existing conflict with another plugin or your theme.

    1.- Temporarily deactivate all your plugins except NextGen Gallery.
    2.- Is the problem solved? Then, it was caused by one of your plugins. Please check one by one and find the one causing the problem.
    3.- If the problem is not solved with the deactivation of the plugins, try changing to a standard WordPress theme, it could be a conflict with your current theme.

    If the problem persists, we might need to report this as a bug.

    Please let us know how it goes.

    – Gaby

    I tried both disabling all plugins and changing to a default theme. Still having the issue. I don’t know what to do, this completely prevents me from updating my site.

    This is definitely a bug. I had my WPEngine team look into this and they couldn’t find a single thing that to fix this error even going so far as to put my live site into a staging area, disabling all the plugins, changing the theme, and making sure the permissions were all correct. The problem persists.

    Thread Starter GCinAZ

    (@gcorrick)

    I also disabled all plugins and got the same error.
    Clearly this is a bug….hoping that it will be corrected!

    Same problem here, hoping for a quick fix.

    Is there any way to roll back to the last version? Or for them to somehow make it available until this is fixed?

    I’m running 3.0.16 now after rolling back and it works fine now. You have to deactivate (not delete!) the plugin and use FTP to copy over a rolled back version of the plugin.

    Same error for me, its not letting me upload images!

    Help.

    Could not write to file. Please check filesystem permissions. Filename: /home/wawr6695/public_html/kiss/00014KissYaleRep-1.png

    Also me, able to upload files from media library, pictures not uploading directly through existing gallery. WordPress 4.9.8 running Mai Lifestyle Pro theme. Using Genesis 2.7.2.
    NextGen Gallery version 3.1.2, NextGEN Pro version 2.6.8

    Plugin Author Imagely

    (@imagely)

    Hi everyone,

    We are sorry but it looks like with the current version of NextGen Gallery, it is impossible to upload PNG images.

    Our developers are currently inspecting this problem and we’ll come back to you with a reply later.

    Mihai

    If it’s not a quick fix please upload the last functional version as if it were a new version so we can all easily get back to business.

    (and yeah, I use .png so that sounds right)

    • This reply was modified 3 years, 5 months ago by matthewblev.
Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Upload Images Get File Permission Error’ is closed to new replies.