Support » How-To and Troubleshooting » Upload image error when using Work-a-holic theme

Upload image error when using Work-a-holic theme

  • Hi,
    I’m using the work-a-holic theme from graph paper press and i’m experiencing an error when trying to upload portrait images. File sizes are fairly small, they vary between 40kb – 150kb. I’ve been digging around for days trying to fix this.

    The error i receive is:
    Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions in /wp-includes/media.php on line 1006

    Warning: imagecopyresampled(): supplied argument is not a valid Image resource in /wp-includes/media.php on line 424

    Warning: imagejpeg(): supplied argument is not a valid Image resource in /wp-includes/media.php on line 455

    I’ve tried a fresh install of WordPress and the theme and database – with no luck.
    I followed the install instructions for the theme and thought leaving the image height blank could be the issue, but adding a value here doesn’t help resolve this.
    Any help you can offer would be great.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator Kathryn


    Automattic Happiness Engineer

    From the theme instructions:

    This theme uses jQuery javascript library to do some fancy stuff. If your theme looks broken, than you likely have a plugin that uses a conflicting javascript library. Deactivate your plugins, one-by-one, to determine which plugin is conflicting with jQuery.

    Have you tried doing what they suggest – i.e. deactivating all your plug-ins to see if there is a conflict somewhere?

    Moderator Kathryn


    Automattic Happiness Engineer

    It may also be a server issue, in which case you might need need to contact your host. See this thread about a similar error and the possible solutions:


    I have tried deactivating all plugins, i’ve also tried a fresh install of wordpress, my database and the theme.

    My host says “I confirm GD Library is present and functional and the server is running php5.2”

    I would prefer not to change themes, as i’ve already spent a fair bit of time setting up bespoke template layouts etc.

    I’m a little stuck on what could be causing this.

    Moderator Kathryn


    Automattic Happiness Engineer

    At that point I would contact the theme developer directly – hopefully they are willing to offer some troubleshooting support. Good luck and do report back on how it goes.

    Thanks, the developer says ” The errors you mentioned are not generated by the theme files but by WordPress core files. Another suggestion is to reinstall WordPress or install a fresh copy of the theme.”

    Which i’ve tried already. I’m hoping to try another webhost shortly, where i can try a fresh upload of everything and try to figure out if its the host, the theme or the recent wordpress update i installed.

    Thanks for your help zoonini. I’ll post back if i get this resolved.


    Moderator Kathryn


    Automattic Happiness Engineer

    What is the width of an image you get this error when trying to upload? Wondering if WP has a maximum image width. If you try an image of say, 500 px wide, do you get an error?

    Are your max widths set to this in the theme settings

    thumbnails – 284
    medium – 600
    large – 940

    …with heights left blank?

    I’ve just tried uploading an image 500 x 633 and i received the same error. I also just uploaded the same image but at 500 x 400 with no error. So its definitely the portrait images causing the trouble.

    The images do upload however and appear in the gallery tab. The medium and large size selection is always inactive – which is why i thought the set-up instructions for leaving the height field blank was the issue! so i’ve tried both blank and adding a height.

    Yes the thumbs are 284, med 600 and large 940

    Moderator Kathryn


    Automattic Happiness Engineer

    Have you pointed the theme maker to the other post where someone reported a very similar issue with the same theme? Could be a coincidence, but perhaps not… Anyway, good luck. 🙂

    Did you have any luck resolving this? I’m experiencing the same problem.

    Hi – no i didnt resolve this, i actually had to start using a different theme.
    I purchased the GPP Workaholic-pro, and that worked fine for me.

    I sent a few emails to them, and they tried to help, but didn’t think it was their theme that was the problem. They got back to me reasonably quick – so i would advise giving them a try.

    Ok. Thanks for responding so quickly. Much appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Upload image error when using Work-a-holic theme’ is closed to new replies.
Skip to toolbar