WordPress.org

Support

Support » Multisite » upload image error http error

upload image error http error

Viewing 15 replies - 1 through 15 (of 42 total)
  • tomontoast
    Member

    @tomontoast

    Can you explain in more detail what happens, is there any error code?

    What happens when you upload from wp-content/media-new.php ?

    hi, sorry for my english 🙂

    i have same problem ;/

    and it is random, some of big jpg is ok and they upload normally some smaller dont – http error

    from wp-admin/media-new.php same situation, some of them are ok some are not but in here if dont i have something like this:

    503 Service Unavailable
    The server is temporarily busy, try again later! Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    all plugin are off

    in 3.4.2 everything was ok…

    tomontoast
    Member

    @tomontoast

    @hhpl Your problem sounds different and is probably due to limited server power, I would contact your server/host provider about this problem.

    ok but what i should tell them ?

    what specifically they should change ?

    tomontoast
    Member

    @tomontoast

    Tell them that the server is too busy too much of the time! They might not be able to do anything if so you might want to change hosts to get a better service.

    but in 3.4.2 everything was ok ;/

    tomontoast
    Member

    @tomontoast

    Try changing back to 3.4.2 to see if this is not a coincidence. There shouldn’t be anything in 3.5 to cause this problem.

    hhpl – Please make your own topic. It makes it harder to help the OP when you do this 🙂

    B_Dark – Have you been able to upload images via WP Admin > Media Library > New ?

    ok, sorry, I thought it was the same problem ;]

    B_Dark
    Participant

    @b_dark

    @ipstenu (Mika Epstein) via the post and via WP Admin > Media Library > New

    Is that a yes or a no, B_Dark? 🙂 Are you getting a specific error on the Media Library one?

    B_Dark
    Participant

    @b_dark

    is yes but no only via WP Admin > Media Library > New, i have the same problem and via the posts to and featured images etc.

    B_Dark
    Participant

    @b_dark

    i uploaded one png image 300×300(208k) everything ok, i uploaded one jpg 220×201(17,9k) everything ok, but when I uploaded one jpg 619×348(247kb) it gave me again “HTTP error” :/

    B_Dark
    Participant

    @b_dark

    My PHP specs:
    PHP Version 5.3.18
    mysql Client API version 5.1.65-cll
    post_max_size 60m
    upload_max_filesize 200m
    memory_limit 128m (local) 1024m (master)
    max_input_time 60
    max_execution_time 600

    My multisite .htaccess is

    # BASIC SECURITY
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    
    php_value memory_limit 128M
    #php_admin_flag safe_mode off
    
    # Prevent folder browsing
    Options All -Indexes
    
    <Files wp-config.php>
    order allow,deny
    deny from all
    </Files>
    
    # BEGIN feedburner and uploaded files adjustments.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_USER_AGENT} !^.*(FeedBurner|FeedValidator) [NC]
    RewriteRule ^feed/?.*$ http://feeds.feedburner.com/mysite [L,NC,R=302]
    RewriteRule ^home?.*$ http://feeds.feedburner.com/mysite [L,NC,R=301]
    RewriteRule ^wp-content/uploads/(.*)$ http://mysite.com/files/$1 [L,R=301]
    RewriteRule ^wp-content/gallery/(.*)$ http://mysite.com/files/$1 [L,R=301]
    RewriteRule ^wp-content/uploads/jw-player-plugin-for-wordpress/player/player.swf$ http://mysite.com/files/jw-player-plugin-for-wordpress/player/player.swf$1 [L,R=301]
    </IfModule>
    
    # BEGIN ANTISPAMBLOG REGISTRATION
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-signup.php*
    RewriteCond %{HTTP_REFERER} !.mysite.com. [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) http://die-spammers.com/ [R=301,L]
    
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post.php*
    RewriteCond %{HTTP_REFERER} !.*mysite.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]
    </IfModule>
    
    # BEGIN Watermark Hotlinked Images
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?mysite.com  [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?google.\ [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?facebook.com [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?twitter.com [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?yahoo.\ [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?bing.\ [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?ixquick.com  [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?feeds.feedburner.com/mysite  [NC]
    RewriteRule ^(.*\.(png|gif|jpe?g))$ http://mysite.com/wp-content/plugins/watermark-hotlinked-images/watermark.php?img=$1 [L]
    </IfModule>
    
    # END Watermark Hotlinked Images
    
    #Begin gzip and deflate
    <IfModule mod_deflate.c>
     AddOutputFilterByType DEFLATE text/html text/css application/x-javascript text/plain text/xml image/x-icon
    </IfModule>
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/html M3600
    ExpiresByType text/css M3600
    ExpiresByType application/x-javascript M3600
    ExpiresByType image/bmp M3600
    ExpiresByType image/gif M3600
    ExpiresByType image/x-icon M3600
    ExpiresByType image/jpeg M3600
    </IfModule>
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    #END WordPress

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘upload image error http error’ is closed to new replies.