Support » Fixing WordPress » “Upload folder is not writable” message showing in Dashboard

  • Resolved wrip

    (@wrip)


    On top of every page I visit in Dashboard is currently showing the message: Upload folder is not writable. Export and file upload features will not be functional.

    I’m using WP 5.1.1. I’ve only recently noticed this message and this is only showing in the staging site. The live site on the same server is fine. wp-content/uploads folder has 755 permissions.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steven Stern

    (@sterndata)

    Support Team Volunteer

    Hmmm…. this must be from some plugin.

    Please disable all plugins and turn them back on one at a time until you find the one.

    Also, check the OWNERSHIP and PERMISSIONS for wp-content/uploads and each subdirectory to verify they’re correct.

    Edit: This may be coming from Gravity Forms. Are you using that plugin?

    • This reply was modified 1 month, 1 week ago by  Steven Stern.
    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Also check the upload_path setting in the wp_options table. This value usually should be blank, but if you have it set to something else, then the wp-content/uploads path may not be what it is looking for.

    Thanks both of you.

    @otto42 upload_path setting is currently empty in the table.

    @sterndata Yes I am using Gravity Forms. When I disabled that plugin, the message was gone. I also noticed that the wp-content/uploads directory had ownership set to ‘root’. So I changed that to the account name. This removed the message from the Dashboard. I think it’s all good now. Do I still need to do something in Gravity Forms settings?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If you corrected the ownership, then that’s likely all the fix needed. Glad you found the problem!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.