WordPress.org

Forums

[resolved] Upload folder is not writable... (7 posts)

  1. allanlud
    Member
    Posted 1 year ago #

    Hi all, I'm getting the following error in the control panel of my WP site.

    Upload folder is not writable. Export and file upload features will not be functional.

    I haven't really changed anything, I had installed the SEO plugin by Yoast and added Google Analytics to the footer.php in theme settings (that was lastnight). I'm sure I had checked and everything was ok, but looking at it today, most of the image on the site are not appearing.

    I've seen some posts on other sites, some people said it is an issue with Gravity Forms (I had deactivated that plugin and it made no difference), other people suggested changing folder permissions, mine are all set to 755, well on folder like 'uploads' and folders within that folder.

    Oh and I've also checked the upload path in settings and it is still 'blank' like it has been for over a year now.

    Any ideas?

  2. WPyogi
    Forum Moderator
    Posted 1 year ago #

  3. allanlud
    Member
    Posted 1 year ago #

    Thanks for the link WPyogi - I did have a read of that already though. I've checked all folders and they are set to 755, 775 and I had changed some to 777 and back to 755 to see if that would work, but I still get that error.

    It seems to be mainly the 2012 folder in the uploads directory, eg. there was 4 social media icons in the footer of the site, now only one is being displayed, it is within the 2013 folder and has an absolute link in the source code, whereas the other 3 are in the 2012 folder with relative links, but there are some other images on the site in the 2012 folder that are displaying - with absolute links.

    Again both these folders are set to 775 and in the settings in the control panel the path is blank, so should be default.

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Link to your site?

  5. allanlud
    Member
    Posted 1 year ago #

    I've removed the 2 rows of images on the home page as they were not displaying.

    link

  6. allanlud
    Member
    Posted 1 year ago #

    Ok I have deactivated the Gravity Forms plugin again to see if the error message would go away and it did.

    So I tried to upload the social media icons in the footer again through the theme options, but it gives this error when uploading and image:

    Unable to create directory wp-content/uploads/2013/08. Is its parent directory writable by the server?

  7. allanlud
    Member
    Posted 1 year ago #

    Ok looks as though I got it sorted.

    Sent Gravity Forms an email about it, they had suggested it was a disk space issue, so I got onto my hosting company (Blacknight), and they were very helpful.

    They had told me that I needed to change the PHP5 support from Run as Apache module to Run as a CGI application and to send them an email and they would update file permissions...

    All sorted now!

Topic Closed

This topic has been closed to new replies.

About this Topic