Support » Plugin: BackWPup - WordPress Backup Plugin » Upload file size and local file size don’t match – only on scheduled backups

  • Resolved maorb

    (@maorb)


    I use BackWPup 3.6.3 on WP 4.9.8

    I created a backup job and set it to upload to Dropbox.
    When running this backup job manually – everything goes well.
    But, when a scheduled backup is taking place, there is an error that keeps showing in the log file:
    “ERROR: Uploaded file size and local file size don’t match.”.
    ERROR: Job has ended with errors in 842 seconds. You must resolve the errors for correct execution.
    When checking in Dropbox – the file is there.
    In the website admin screen, it says the local backup file size is 118.09MB and the dropbox is 122.09MB, and in another scheduled task the log said it’s 121.63MB local, and the dropbox shows file size of 125.63MB.

    When trying to downlod the tar.gz backup file from Dropbox and trying to extract it – it fails at the end with error that file is corrupted.

    Why is this file size issue occurs and how could it be fixed?

    Thanks ahead

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi @maorb

    When trying to download the tar.gz backup file from Dropbox and trying to extract it – it fails at the end with the error that file is corrupted.

    What BackWPUp version did you use? also, I think you are using Windows, so the issue file corrupted may happen, please try using Winrar to open that tar.gz backup file. Is that help?

    Thread Starter maorb

    (@maorb)

    Hi @duongcuong96
    Thanks for your reply.
    I use BackWPup 3.6.3 on WP 4.9.8.
    My local computer is PC, but of course the webserver of the site is Linux based.
    I used Winrar to extract the tar.gz backup file when got this error.
    Also, please note that when manually running the backup job, all is correct, and I can download the tar.gz file and successfully exratct it with no error messages.

    Also, the log file that is created by BackWPup is on the webserver and it points to this error, which is before I try to download it from Dropbox.

    What else could cause this issue?

    Thanks

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @maorb
    Please try the following:
    – go to BackWPup > Settings > Jobs, try to set Maximum Script Execution Time setting to about 20 seconds

    – go to BackWPUp -> Settings -> Job tab -> Reduce server load and choose medium

    After that, run the job again, is that works?

    Thread Starter maorb

    (@maorb)

    Hi @duongcuong96,

    – The Maximum Script Execution Time was already set before to 120 seconds.
    – I’ve set the Reduce server load to medium instead of disabled.

    Next scheduled backup job will occur in about 27 hours, so after that I’ll update if it helped.

    Thanks a lot

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @maorb
    hope my fix will help 😀

    Thread Starter maorb

    (@maorb)

    Hi @duongcuong96,

    The last auto scheduled backup was successfully completed, and the tar.gz file was extracted with no errors.
    It appears that the Reduce server load setting to medium, has solved that issue.

    Thanks a lot for your help!

    Plugin Support duongcuong96

    (@duongcuong96)

    @maorb
    Glad that it’s working for you :),
    If you have any question or issues about BackWPUp, feel free to let us know 🙂
    Have a nice day :).

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support 😀
    https://wordpress.org/support/plugin/backwpup/reviews/

    Thread Starter maorb

    (@maorb)

    Done, @duongcuong96 🙂

    Many thanks for your help

    Thread Starter maorb

    (@maorb)

    Well, that error in the log appeared again in the last backup yesterday.
    Here I attach part of the log file:

    [07-Dec-2018 02:16:01] 1. Try to send backup file to Dropbox …
    [07-Dec-2018 02:16:02] Authenticated with Dropbox of user: *****
    [07-Dec-2018 02:16:02] Uploading to Dropbox …
    [07-Dec-2018 02:16:02] Beginning new file upload session
    [07-Dec-2018 02:22:58] WARNING: Job restarts due to inactivity for more than 5 minutes.
    [07-Dec-2018 02:22:58] 2. Try to send backup file to Dropbox …
    [07-Dec-2018 02:22:58] Authenticated with Dropbox of user: *****
    [07-Dec-2018 02:22:58] Uploading to Dropbox …
    [07-Dec-2018 02:29:01] WARNING: Job restarts due to inactivity for more than 5 minutes.
    [07-Dec-2018 02:29:01] 3. Try to send backup file to Dropbox …
    [07-Dec-2018 02:29:01] Authenticated with Dropbox of user: ******
    [07-Dec-2018 02:29:01] Uploading to Dropbox …
    [07-Dec-2018 02:29:11] Finishing upload session with a total of 119 MB uploaded
    [07-Dec-2018 02:29:14] ERROR: Uploaded file size and local file size don't match.
    [07-Dec-2018 02:29:17] 4. Try to send backup file to Dropbox …
    [07-Dec-2018 02:29:17] Authenticated with Dropbox of user: ******
    [07-Dec-2018 02:29:17] Uploading to Dropbox …
    [07-Dec-2018 02:29:18] ERROR: Job has ended with errors in 1725 seconds. You must resolve the errors for correct execution.
    

    Do you have any more ideas what may fix this?

    Thanks

    Plugin Support duongcuong96

    (@duongcuong96)

    @maorb

    – The Maximum Script Execution Time was already set before to 120 seconds.

    Is it possible for reducing it to 20 secs since I see the warning may happen because the server stopped BackWPUp progress because it’s running too long?

    Thread Starter maorb

    (@maorb)

    @duongcuong96
    The weired thing is these warnings too in the log file –
    WARNING: Job restarts due to inactivity for more than 5 minutes.
    Why there is so long inactivity?

    I think I’ve tried a lower Script Execution Time before, but anyway I’ve changed it again and reduced it from 120 to 20 secs.

    Next scheduled backup should occur in about 30 hours, so I’ll check how it will go and update here later.

    Thanks

    Thread Starter maorb

    (@maorb)

    @duongcuong96

    Here to update – the issue hasn’t occured in the last scheduled run, so it’s oke now. I’ll update again if error will return on next schedule next week.

    Anyway, now there a new warning error messeage from the server, in the admin panel page of the Manage Backup Archives admin page.
    It doesn’t affect anything, but why it’s there?

    Warning: mime_content_type(/****/public_html/wp-content/uploads/backwpup-814aa8-temp/*****_backup_2018-12-14_02-00-11_GSAUVKF301.tar.gz): failed to open stream: No such file or directory in /****/public_html/wp-content/plugins/backwpup/inc/class-destinations.php on line 131

    Thanks

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @maorb,
    Could you update BackWPUp to the latest version 3.6.6 then try again? I remember this issue has been fixed now :/

    Thread Starter maorb

    (@maorb)

    @duongcuong96 Thank you, after updating plugnin to 3.6.6 this warning has been disappeared.

    Plugin Support duongcuong96

    (@duongcuong96)

    @maorb
    That great to hear 😀
    merry Christmas and happy new year!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Upload file size and local file size don’t match – only on scheduled backups’ is closed to new replies.