Support » Plugin: Visual Form Builder » Upload file (location & attached to email)

  • Hi Matthew,

    I have a form setup that includes a File Upload and I was expecting it to send an email with the file as an attachement or a link to the file. Apparently it either doesn’t do it, I’m not doing something correct or I’m not looking in the correct place.

    Is there a way that when someone uploads a file with their form an attachment or link shows in the email? If not, how and where do I go to retrieve the file that was uploaded?

    Thanks a million in advance!

    Jason

    http://wordpress.org/extend/plugins/visual-form-builder/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Sorry – one more note that may be important. I want the file that’s uploaded to be an MP3. I did change the file type in the “accepted file extentions” to mp3.

    Plugin Author Matthew Muro

    (@mmuro)

    All of what you are describing is a part of VFB. Attachments are included and a link to the attachment is inserted into the email.

    If you are having problems, it could be a file permissions issue.

    Also, one other little thing. Just because you put the extension into the Accepted File Extensions box, doesn’t mean that file type is allowed. WordPress restricts certain file types (known as mimes) and you can hook into a filter to add or remove ones that are not allowed by default. MP3, however, is an allowed file type.

    Thanks Matt,

    Is the file permission issue something I can address in VFB or is that a theme, wordpress or server issue?

    Jason

    I guess a better question is what file and what value do I need to change? I see there is an option to select or unselect User/Group/Other for Read/Write/Execute and then there is a box for a number value. I’m just not sure which file to modify. I found the visual-form-builder.php. Currently only User can read/write and group and other can only read. The value is also set at 644. Is that where I need to make my change?

    Plugin Author Matthew Muro

    (@mmuro)

    No, you are going to want to look at your wp-content folder.

    http://codex.wordpress.org/Changing_File_Permissions

    I’m not a coder so perhaps it might be easier for someone that is. I read the entire post about Changing File Permissions and I did as you instructed and changed the permissions on the wp-content to 755 and eventually to 777 and it still didn’t work. I even went into wp-content and made all of those folders 755. The only things I didn’t change to 755 and kept at 644 where the individual php files. I am working with the pro version. Is there supposed to be an “attach” button or once I select the file and click submit does that automatically attach it? I know Matt is extremely busy so if anyone else reads this post and has any suggestions – please let me know! I’d hate to try a different form because I use VFB on everything I do.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Upload file (location & attached to email)’ is closed to new replies.