Support » Plugin: WP-Stateless - Google Cloud Storage » upload error after initial install

  • I have tried both the wizard and the manual instructions but still getting the error below. I tried fussing around with different settings and double checked my service account and permissions … it all seems fine but I can’t upload any test images.

    I am using AppEngine flexible environment. I unzipped the plugin into \wp-content\plugins before using gcloud SDK to deploy to our GCP environment. Any ideas?

    Unable to create directory wp-content/uploads/2018/10. Is its parent directory writable by the server?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Eric Sopp

    (@ideric)

    I believe AppEngine is the issue. This plugin is not compatible on the platform. It has something to do with how AppEngine and GCS interact that prevents it from working as expected.

    Thanks, Eric. We want to use AppEngine but obviously need to have some persistent storage. This wp-stateless plugin looks much better than the one which came bundled with the WP distribution – tutorial / Git example which I have been working on. I will put a link below in case you want to see it.

    If this ever does support AppEngine we would take another look.

    https://cloud.google.com/php/tutorials/wordpress-app-engine-flexible

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘upload error after initial install’ is closed to new replies.