Support » Fixing WordPress » Upload Error

  • For about 3 days now every time I try to upload a image I get a IO error.
    And next to the jpg I’m trying to upload reads; An error occurred in the upload. Please try again later. Doesn’t seem to matter what image I upload or what size it is.

    Would really appreciate any body shedding some light on why it happens and how to stop it.



Viewing 3 replies - 1 through 3 (of 3 total)
  • I am experiencing the same problem. I installed WordPress 2.6.2 and everything worked fine for a couple days. The changes I made prior to the problem appearing were: install new theme (Esther) and setup URL Rewrites.

    I have done the following since the problem appeared:

    • Checked my flash and browser version:
      Flash: MAC 9,0,124,0
      Browser: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv: Gecko/2008092414 Firefox/3.0.3.

      Even though they are up to date I uninstalled and re-installed my flash just for kicks, and still no joy.

    • Tried clearing browser cache and that did nothing.
    • Remove URL Rewrites, upload still failed.
    • Tried a suggested fix to add a mod_security rule in the .htaccess file:
      <IfModule mod_security.c>
       <Files async-upload.php>
        SecFilterEngine Off
        SecFilterScanPOST Off

      and this did not work so I thought I would add the path to the file in the rule so it read /wp-admin/async_upload.php and still no change.

    So I also would appreciate anyone’s help to clarify this problem, because the main reason I setup this blog was so my wife could use it post stuff about our family but she hates using it because of the bugs. Here is the site: blog

    I have since spoken with my web hosting provider and they do not have mod_security installed because it is a shared environment. So if anyone has that module installed and is willing to try it, that might fix the problem. I am currently in the process of changing my hosting provider because they are a bit out dated. So we will see how it goes.

    So I finally fixed the flash io upload error for our blog. I turned off the forced https:// for the blog. I have been using a shared SSL Certificate and I am not sure yet if it was just the change in URL or the shared cert that was causing it. I hope that helps anyone else looking for help on this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Upload Error’ is closed to new replies.