WordPress.org

Support

Support » Installation » Upload error

Upload error

  • Hi ,
    I have installed the wordPress 2.5 on subfolder in my site ( http://www.*****.com/wordpress

    The word press is runing fine but i can not UPLOAD any image , I get the error message : HTTP error.

    I tried to set the uploads folder that located in wp-content folder to the permission 777 & 755 and the same error message continues ..

    I contacted my host and the told me that phpsuexec is runing on our server and better to ask the WORDpress support about the right permission for phpsuexec server

    Thanks alot

Viewing 15 replies - 16 through 30 (of 66 total)
  • <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Worked like a charm… thank you.

    @lsrn94:

    You are my hero. This should be in the FAQ. I’ve been messing with this since the 2.5 nightlies started coming out and did not find a solution until now.

    @lsrn94
    Where do you put that code – is there anything else that should be in an .htaccess file or just that??

    I have tried putting the above .htaccess file in my wordpress directory, and yet I still can’t upload.

    There’s a ton of threads on this, so I hope it gets resolved soon.

    edit: I found the culprit for me. I turned off the Bad Behavior plugin and was then able to upload freely.

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    @lsrn94#permalink

    Thanks, this work like charm
    i’ve tried more than 5-8 method mostly from discussion here and this worked for my subdomain wordpress installation
    not sure how will it work in root domain tho..

    @my-step
    create directory uploads – chmod 775 – go to option in wordpress..save the permalink setting and it will create the htaccess and add the above line before end of # END WordPress

    again thanks..

    i have tried all the tips above, but still gets ‘http error’ – ‘an error has occoured, please try again later’ when trying to upload.

    i was stupid enough to upgrade without trying this first so i had to install a plugin-uploader, but i really hope for a solution on this…

    thanks.

    I am having these problems as well, and none of the solutions above seem to work.

    LSRN94’s solution (above) worked for me… thank you, thank you!

    I also double-checked my CHMODs on all relevant wp-content folders, to be sure that I could write to them from WP.

    That combo seemed to work just fine. HUGE sigh of relief!

    When I try to upload an image, I get this:

    “The uploaded file could not be moved to”…

    My host has confirmed that Mod_Security is turned on and that they can’t turn it off. The .htaccess solution did not work for me. Is there any other way around this or do I have to wait for another version of WordPress? Bummer!!

    The Bad Behavior plugin was the issue for me, but the .htaccess fix was also required.

    I tried this one too, the .htaccess solution didn’t work for me…

    Is there any “old-style” upload plugin I could use to keep adding images to my blog?

    Thanks in advance !

    I had almost the same error in the final version of 2.5.

    All it said was “crunching” nothing else. I chmod my upload folder to 775 and added the htaccess code and now it works. 🙂

    I’m not a techie, so I may be missing something, but I’ve had the same problem as everybody else (it seems), not being able to upload pictures. I followed LSRN94’s tip about the Mod_Security, and everything worked fine… for a short while. After a while my whole WordPress installation just crashed. I had to do a whole clean install, deleting everything on my server a couple of times before I got it right.

    Now, the whole thing might not have had to do with the htaccess-file, but my error log was full of mentions of the htaccess and Mod_Security. Whatever the case, I contacted my server admin, and he gave me just one line to put into the .htaccess-file:
    SecFilterEngine Off
    I did that and everything has worked fine for me since. Hope this helps someone and confuses few…

    LSRN94’s .htaccess gets rid of the HTTP error.

    but now i’m stuck with The uploaded file could not be moved to /home […] wp-content/uploads/2008/04.98 or wp-content/uploads/.90 (when Organize my uploads into month- and year-based folders is off)

    what’s .98 and .90?

    chmodding does nothing.

    help?

    OK, my crach was caused by the htaccess-file. My new revised htaccess worked for some hours, before I again encountered 500 Internal Server Error. I deleted the htaccess-file and all is well again. But I can’t upload pictures…

    Any other ideas?

Viewing 15 replies - 16 through 30 (of 66 total)
  • The topic ‘Upload error’ is closed to new replies.
Skip to toolbar