Support » Plugin: Custom Field Template » Upgrading to version 2.1.2 causing errors

  • I upgraded to version 2.1.2 and then started seeing this error in the back end:

    Warning: array_map() [function.array-map]: Argument #2 should be an array in /website/wp-content/plugins/custom-field-template/custom-field-template.php on line 294

    When I try to save a page post I get:

    Warning: Cannot modify header information – headers already sent by (output started at /website/wp-content/plugins/custom-field-template/custom-field-template.php:294) in /website/wp-includes/pluggable.php on line 876

    Downgrading back to version 2.1.1 removes the errors.

    http://wordpress.org/extend/plugins/custom-field-template/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m also getting errors after upgrading that prevent me from updating posts. Something like:

    Warning: array_map() [function.array-map]: Argument #2 should be an array in /home/public_html/wp-content/plugins/custom-field-template/custom-field-template.php on line 294
    (showing up in the CFT box on the post above where the Template Instruction shows up).

    Same here.
    My 0.02 => it’s important to develop plugins with WP_DEBUG enabled.

    Same here. I downgraded back to version 2.1.1
    http://wordpress.org/extend/plugins/custom-field-template/developers/

    Same here! Please can this be fixed.

    Same issue for me, but only in local environment. On the live site it works without errors.

    I’m getting errors with spanish characters in fields names since upgrade.

    Edit:

    Weird behavior: error fixed when post saved.

    Same here. Only downgrading back to 2.1.1 fixed it.

    I’m getting this message when I save a post or page:

    Warning: strtolower() expects parameter 1 to be string, array given in /website/wp-includes/formatting.php on line 981

    Warning: Cannot modify header information – headers already sent by (output started at /home/wesfal1/clg/wp-includes/formatting.php:979) in /website/wp-admin/post.php on line 233

    Warning: Cannot modify header information – headers already sent by (output started at /home/wesfal1/clg/wp-includes/formatting.php:979) in /website/wp-includes/pluggable.php on line 896

    Some times the just entered content is saved and some times not. This only began happening after the latest update (and goes away when the plugin is deactivated).

    Any ideas?

    Would reverting to earlier version remove my existing templates?
    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Upgrading to version 2.1.2 causing errors’ is closed to new replies.