Support » Plugin: Relevanssi - A Better Search » Upgrading to PHP 7.2

  • Resolved StephenEquus

    (@stephenequus)


    Hi. We ran WPEngine’s PHP Compatibility Checker plugin in preparation for PHP 7.2 and we got the following errors/warnings. I found an support post where someone asked about compatibility for PHP 7.0 – I just want to check on compatibility for PHP 7.2. Thanks.

    FILE: /wp-content/plugins/relevanssi-premium/lib/cache.php
    FOUND 5 ERRORS AFFECTING 5 LINES
    12 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    23 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    24 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    49 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    50 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ———————————————————————————————————–
    FILE: /wp-content/plugins/relevanssi-premium/lib/indexing.php
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    10 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————

Viewing 1 replies (of 1 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Your version of Relevanssi Premium is over two years old, and I would very much recommend against running a version that old on a production site; it is not safe to use.

    Current versions of Relevanssi and Relevanssi Premium are safe and compatible with PHP 7.2. (The version you have is also PHP 7.2 compatible, just not safe.)

Viewing 1 replies (of 1 total)
  • The topic ‘Upgrading to PHP 7.2’ is closed to new replies.