Support » Fixing WordPress » Upgrading to 3.6.1 broke media library

  • It was working fine, but now the images in Media Library cannot be accessed by using the “Add media” button on the post. You can upload an image but get an error message “An error occurred in the upload. Please try again later.”
    If you look in Dashboard>Media>library it and the other photos are there.
    The current directory is: /public_html/nhs/wp-content/uploads

    I created another site recently and it’s library is located at:

    What file do I edit to change the path? I can’t seem to find it.

    PS: I have tried the following methods which did not work:
    I disabled all plugins.
    I changed to Theme Twenty-Twelve.
    I unchecked organize my uploads into month- and year-based folders.

    I tried … Check that anti-hotlinking of images isn’t enabled in your hosting account. If it is, try disabling it.
    – Check your uploads path in Dashboard, Settings, Media, Store uploads in this folder . . . normally this would be blank.
    – Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777.
    Once your uploads are working, change the permissions on wp-content back to 755 …

    Help. Just help. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p


    – If all the above troubleshooting steps you described fail to resolve the issue, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!
    Always backup everything (including your database) before doing any actions, just in case.

    Reinstalling fixed it. Thanks!

    Moderator t-p


    you are welcome 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Upgrading to 3.6.1 broke media library’ is closed to new replies.