WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrading to 3.5 Fatal error (18 posts)

  1. jholcombkw
    Member
    Posted 2 years ago #

    I am getting the error when I am trying to login to wp-

    Fatal error: Call to undefined function get_taxonomies_for_attachments() in C:\HostingSpaces\springfieldaquariumshoppe.com\wwwroot\wp-admin\menu.php on line 67

    Line 67 is

    foreach ( get_taxonomies_for_attachments( 'objects' ) as $tax ) {

  2. teshno
    Member
    Posted 2 years ago #

    me too, same problem, any one any ideas?

  3. keesiemeijer
    moderator
    Posted 2 years ago #

    try:
    - reading the troubleshooting 3.5 master list to see if any of your problems is listed there: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list

    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - re-uploading all files & folders - except the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides (Manual Update).

    - re-running the upgrade via wp-admin/upgrade.php

  4. ben_giff
    Member
    Posted 2 years ago #

    I'm having the same problem. How can I deactivate plugins or switch themes if I can't log into my dashboard?

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 2 years ago #

    ben_giff: Removing plugins or themes can be done via FTP by simply renaming or deleting their folders.

  6. jholcombkw
    Member
    Posted 2 years ago #

    Is there away to go back to 3.4?

  7. jholcombkw
    Member
    Posted 2 years ago #

    I removing all plugins and still getting the same error

  8. LondonCabbie
    Member
    Posted 2 years ago #

    I too am getting:

    Fatal error: Call to undefined function get_taxonomies_for_attachments() in /websites/123reg/LinuxPackage22/ca/bb/ie/cabbieblog.com/public_html/blog/wp-admin/menu.php on line 67

    I can't log into my administrator panel

    I've reset my plugins folder via FTP or the file manager provided in your host's control panel as follows:
    1. Via FTP or your host's file manager, navigate to the wp-contents folder (directory)
    2. Via FTP or your host's file manager, rename the folder "plugins" to "plugins.hold"
    3. Login to your WordPress administration menus (/wp-admin)
    4. Via FTP or your host's file manager, rename "plugins.hold" back to "plugins"

    WP is still not allowing me to log in

  9. jholcombkw
    Member
    Posted 2 years ago #

    It will not let me login too! How can I go back to 3.4?

  10. This is not a theme or plugin conflict. It is from a failed upgrade.

    get_taxonomies_for_attachments() is a new function introduced in 3.5 and is defined in wp-includes/media.php

    If your getting an undefined function error for it you still have the old media.php file and your update failed.

    You will need to manually re install 3.5 following the codex Manual Update instructions.

  11. gaznev2000
    Member
    Posted 2 years ago #

    i'm getting the same. :-|

  12. calik1d
    Member
    Posted 2 years ago #

    Supposing you backed up everything. Do a clean install if you want to go back to 3.4

  13. ben_giff
    Member
    Posted 2 years ago #

    The manual update seemed to fix everything. Thanks!

  14. Trish Cortez
    Member
    Posted 2 years ago #

    I have been looking for answers since my upgrade on Tuesday- Which has Frozen me out of my website. Every Forum I log into- the topic get closed each time I entered it!

    My blog is not working- prior to logging out (now can nver get back in) I deactivated ALL plug ins- Cleared History and Cookies, Tried IE 9-nothing, Firefox-nothing, Chrome-nothing- My hosting company says I have a healthy server/connection... THAN WHY AM I FROZEN... tonight I have a fatal error. and now I can't see anything or do anything- Does anyone have any suggestions.. Before the upgrade- I had no issues with my theme or anything else- upgrade and BOOM- no more... LOOKING FOR HELP!!
    Trish
    StampingWherepapercomesalive.com

  15. minht49
    Member
    Posted 2 years ago #

    Hi, after automated upgrade to wordpress 3.5 I am not able to log in to my admin. I get this Warning: Missing argument 2 for wpdb::prepare(), called in /home/minht49/public_html/wp-content/plugins/digiproveblog/CopyrightProof.php on line 810 and defined in /home/minht49/public_html/wp-includes/wp-db.php on line 990

    Can someone show me how to fix this, I am fairy new to wordpress, and am tired of deleting my webpage and starting a new one. Thanks

    Also how do I go to ask for help on wordpress, sorry for borrowing this one.

  16. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Yes, it's best to start a new thread which you can do here:
    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    (It's at the bottom of each forum page.)

    But the error message you're seeing is discussed in this list of known 3.5 problems:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    In your case, it looks like it's coming from the digiproveblog plug-in?

  17. minht49
    Member
    Posted 2 years ago #

    Thanks for your help WPyogi, I'll read those threads you pointed, and give it a shot.

    Thank You, for your help.

    Minht49

  18. DigiproveDevelopment
    Member
    Posted 2 years ago #

    minht49 - the solution to that that specific problem of yours is available at http://wordpress.org/support/topic/doesnt-work-with-wp-35-36?replies=13

Topic Closed

This topic has been closed to new replies.

About this Topic