Support » Themes and Templates » Upgrading to 3.0 – do themes need to be amended/made compatible?

  • Resolved pinkbeats

    (@pinkbeats)


    Hi,
    Do existing themes have to be modified extensively to be compatible with WordPress 3.0? I only ask because the theme author for the one I’m using (Stealth Gray Mix 2.5.1) with my blog doesn’t seem to be providing support for it. I’ve tweaked the theme anyway and am fairly confident with modifying things as long as there’s some guidance.

    At the moment I don’t want to upgrade to 3.0 in case it breaks with the theme as is, the other alternative is to choose another theme that is compatible with 3.0 but that will bring it’s own set of problems as I’m sure I’ll have to modify it to get it displaying how I want.

    An advice gratefully received. Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The theme should be fine.

    If it worked on 2.9.2, it should work now. You won’t be taking advantage of new WP features, but it shouldn’t break.

    I designed my theme back on WP 2.6 something, upgraded it at 2.8 to take advantage of threaded comments and thumbnails, but no other changes. Now I just upgraded to 3.0, and then spent about 10 minutes swapping out the old menu system for the shiney new one. It worked fine after the upgrade, I just wanted the new menus…

    Thanks for the reassurance – upgrade went well and blog is still there.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Upgrading to 3.0 – do themes need to be amended/made compatible?’ is closed to new replies.