Support » Fixing WordPress » Upgrading to 2.8 killed all my pages, 404 error

  • Since upgrading to 2.8 none of my pages work anymore.


    I have tried readding them, resaving permalink settings, reloading the htaccess file, everything I can think of, nothing works.

    Default theme has the same problem too.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Do you access this page if you use the default link (with post id inside)?
    If so, I would have a look at the htaccess (go in your settings to get the code and update your htaccess file)


    You might have some links issues: your “contact us” link sent me to “” which of course isn’t going to work!
    (looks like a mix with the link you have in your forum)

    Where exactly is the link for that staff page which is broken?

    Also check in admin that the slug for staff is really staff and not staff1 or I don’t know what

    EjMama, I cant even access it with the default link, I get a Page Not Found error regardless if permalinks are turned off or on.

    Right now the page is not being linked to anywhere because the link is broken, using page list plus I can hide it, and no, deactivating that plugin does not fix it. I had all plugins deactivted with default theme and it STILL did not work.

    As for the link it the footer. Wow, that looks like another 2.8 bug, not matter how I save the footer it adds \’s to the URL. Weird.

    Great, more upgrade problems. It so was not worth it to be honest. 2.7 worked PERFECTLY.

    swyx: that’s because that is a blog POST, not a PAGE. But thank you for replying.

    It’s not that your page is now unpublished, or in an unpublished category?
    Can you see other posts from the same category?

    ^^ I cant see ANY pages anymore. They used to work just fine, now they dont. They are all published. Everything is set up fine to work, Ive checked over and over again.

    However I made a mistake in my previous post, turning permalinks off and going to DOES work. But with permalinks on it redirects to a 404. So it is definitely a redirect error that has come up somehow since the upgrade.

    My .htaccess file has not changed, and the redirects are internal anyway right? the rewrite.php file has not changed. Ive tried chmoding it to 777 and saving the page again thinking it might update something, but it still does not work at all.

    Maybe you do need to change your htaccess, because maybe the new version uses a different way to do permalinks?
    If I were you I would set up permalinks and update my htaccess with the code provided in your admin, just in case :/

    ^^^ I have done that, as mentioned in the first post.

    No luck.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    What are your permalink settings? Are you using some kind of custom permalink string? Are you using any permalink modifying plugins?

    And if 2.8 doesn’t work for you, then roll back to 2.7. You did make a backup before you upgraded, yes?

    I made a back up yes, but my website gets updated daily, so the old backup is obsolete now.

    I am not using any permalink modifying plugins, and in fact even when ALL plugins are disabled it still doesnt work.

    The only permalink string I am using is for posts, and this does not affect posts only pages. Anyway that is /%category%/%postname%/

    The category base has been renamed to section, but even with it as default it does not work, and categories dont apply to pages anyway do they?

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Well, one problem could be your use of /%category%/ as the leading parameter in the permalink string. Try using one of the default options, without %category% in it. See if that changes anything.

    Switching to Month and Name fixes the problem. But in my case this is not something I can do. I need it to be /%category%/%postname%/ for my google standings as this is what I was running before I moved over to WordPress. Considering there is a screenshot of /%category%/%postname%/ on the documentation website, I would have thought it was pretty standard.

    But now we know the problem so we are one step closer to finding a solution 🙂

    I did a little testing.

    That works.

    This doesnt:

    So it appears that it is not the fact that it has catagory in front of it, but that it DOESNT have the date in front of it.

    Any solution?

    At this point, the way my site is indexed, I cant change link structures. But like I said, I expected /%category%/%postname%/ to work seeing as there is even a screenshot of it on the website.

    Hi, I’m having this same problem except that when I changed my permalinks to day and time, in IE8 instead of a 404 i now get “CGI Error – The specified CGI application misbehaved by not returning a complete set of HTTP headers.” Firefox still returns a 404 …

    In my case, no posts, cats, or pages work at all, only index.php.

    Any help is appreciated.

    Here’s something mildly interesting: works, does not.

    Web server is IIS. Yes, I’ve read some things on wordpress & IIS, tried the wp-db.php replacement, failed. Anyway, 2.7 worked, 2.8 doesn’t. So not sure where to go from here, any help appreciated.

    ^^ Can you please tell me what gives you in IE? I cant because im running macosx.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Upgrading to 2.8 killed all my pages, 404 error’ is closed to new replies.