WordPress.org

Support

Support » Installation » upgrading to 2.2.2

upgrading to 2.2.2

  • Liamini
    Member

    @liamini

    I’m totally flummoxed! I’ve been trying to upgrade to 2.2.2 and after reading through the upgrade instructions, I tried to backup WP but haven’t gotten very far. My host is using phpMyAdmin – 2.8.0.1 which kinda looks like the one described in the Backup docs but doesn’t work the same way.

    I got as far step 8, ‘Save as file’ and indeed I downloaded a file called

    ‘mysql0.fast.net.uk.sql’ 704k in size

    But this is where it all goes pear-shaped as in Step 9 I check the zipped option to download the next file and I get a file called ‘mysql0.fast.net.uk.sql.zip’ but it’s NOT the next file as there’s no way of selecting the next file and in any case when I tried downloading, instead it opened all the code in a new page!

    The problem is there doesn’t seem to be a way of selecting the next file to download. On the left-hand side of the screen is the following list:

    wp_categories
    wp_comments
    wp_link2cat
    wp_links
    wp_options
    wp_post2cat
    wp_postmeta
    wp_posts
    wp_sticky
    wp_usermeta
    wp_users

    Which if I click on one of them eg wp_categories, I get a new page which shows all the contents.

    Oh yeah, on the admin page there’s an option to select all, which I did before downloading the above.

    So have I downloaded everything I need or what?

    Bill

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m not quite sure from what you’ve said. You could try opening the file you downloaded in a text editor and see whether all the tables are there.

    Anyway, rather than use phpMyAdmin, I recommend using the wp-db-backup plugin. Until recently, this was shipped as standard with WP – in my opinion, it’s a pity they have stopped doing that.

    You can download it here:
    http://ilfilosofo.com/blog/wp-db-backup

    It lets you back everything up straight from the WP admin screen.

    Liamini
    Member

    @liamini

    thanks, I’ll check it out. As to my description, it’s almost impossible to include the entire process without actually seeing it, but if you look at the WP docs, I’ve followed the instructions up to Step 9 faithfully.

    Bill

    Liamini
    Member

    @liamini

    Drat!

    I don’t have write permissions!

    WARNING: Your wp-content directory is NOT writable! We can not create the backup directory.

    /www/business/5382/wp-content/backup-40ae7/

    Bill

    whooami
    Member

    @whooami

    then you chmod the necessary directory(ies) — you are the owner of the files, you CAN do that.

    http://codex.wordpress.org/Changing_File_Permissions

    Liamini
    Member

    @liamini

    Unfortunately not, the company that hosts WP have not given me write permissions EXCEPT for the wp_uploads directory in the wp_content directory. I’ve asked them to extend the permissions to the entire wp_content directory.

    Bill

    justinratwebtek
    Member

    @justinratwebtek

    If you can’t control all of your own webspace, you may want to find another host. I can understand them being careful, but unless they have basement bargain pricing, I’d move.

    If they will not extend the privileges, give them the location of the plugin and have them install if for you (then move away with the back…)

    …Granted, I’m more advanced and have a full server, but thats crazy. I’ve never had a host control my directories.

    whooami
    Member

    @whooami

    wowo! My apologies for assuming….

    That sucks, and I agree — change hosts

    And I really would encourage anyone with the necessary skill (not much needed) to switch to ssh/svn.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘upgrading to 2.2.2’ is closed to new replies.