Support » Fixing WordPress » upgrading plugins in 2.8

  • I have successfully upgraded to 2.8, or so I thought. This morning I had 2 plugins to update. When I try to update them, I receive these messages

    Comment-Luv
    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    TinyMCE

    Warning: unpack() [function.unpack]: Type V: not enough input, need 4, have 0 in /home/trac7032/public_html/leadingfromtheheart.org/wp-admin/includes/class-pclzip.php on line 4770
    
    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    Will I no longer be able to update my plugins? Both of them indicate an invalid archive structure.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Tracy
    Have you tried to upgrade by FTP instead?

    you mean upgrade the plugin? wouldn’t that mean that there is still something broken with wordpress since I can’t use the automatic plugin upgrade feature that has always been a part of wp?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    That error usually indicates that it had a bad download. This happens from time to time. Sometimes it happens when the ZIP is still being rebuilt. Generally you try again later on that error, or upgrade them manually via FTP.

    Plugins are not working for me in 2.8 either, and it looks like from the forums that it’s happening for a lot of other people. Is this a systemic issue?

    Same here, I get this with ALL six plugins that need upgrading.

    Well, I just tried it again and the issue seems to have worked itself out. I successfully updated the plugins that weren’t updating a few days ago.
    Nice.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘upgrading plugins in 2.8’ is closed to new replies.