Support » Fixing WordPress » Upgrading PHP from 5.1.6 to 5.2.4 broke WordPress

  • BazJscott

    (@bazjscott)


    Yesterday WP 3.1.4 was running fine on PHP 5.1.6. Today after PHP was upgraded to 5.2.4 it has all fallen apart. Most of the modules on the dashboard including “Incoming Links”, “WordPress Development Blog”, “Other WordPress News”, “Plugins” and “Stats” are broken, some display “RSS Error: WP HTTP Error: connect() timed out!”

    If I try to update to 3.2 using the auto update and FTPS I get the error “Error: There was an error connecting to the server, Please verify the settings are correct.” and if I try using FTP the error “Downloading update from http://wordpress.org/wordpress-3.2.zip…Download failed.: connect() timed out!Installation Failed”

    Any help would be greatly appreciated

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    (@esmi)

    Forum Moderator

    That sounds like a bad server upgrade to me.

    BazJscott

    (@bazjscott)

    The host says they have checked and it is fine. Is there anyway to test it at all?

    Any other suggestions?

    BazJscott

    (@bazjscott)

    The host has let me know it was a problem with Plesk being updated at the same time, it lost the custom firewall settings. They have added some rules for the usual wordpress services and I was able to update wordpress to 3.2 but unfortunately stats and incoming links still do not work.

    Does anyone have any idea of how to open up these services too?

    Moderator Samuel Wood (Otto)

    (@otto42)

    Sounds like you’re behind a firewall, so it can’t connect to external servers via HTTP. Tell them you want the site to be able to connect to arbitrary servers over HTTP. Those feeds come from google, planet.wordpress.org, and several other places.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upgrading PHP from 5.1.6 to 5.2.4 broke WordPress’ is closed to new replies.