Support » Installing WordPress » Upgrading issue

  • Resolved Dave

    (@drobbins1)


    I ran into a couple of issues trying to update my blog tonight.

    1. My blog dashboard says that I should upgrade from 2.6.2 to 2.8.4, but when I do, it says that I am up to date and do not need to upgrade.

    2. I went ahead and tried to change my pages to the new template format. It went somewhat OK, but I am getting an error in the blog navigation:
    Quote
    Fatal error: Call to undefined function get_search_form() in /virtual/users/e15586-16411/web/wordpress/wp-content/themes/wxblog/sidebar.php on line 10
    The sidebar.php is in the correct directory though.

    I believe line #10 s
    <?php get_search_form(); ?>

    3. It is also missing the footer.php and all my old blogs. Will this be corrected once #2 above is fixed?

    http://www.cavecountryweather.com/wordpress/

Viewing 9 replies - 1 through 9 (of 9 total)
  • It seems like a theme issue. Is that a custom theme?

    Try switching to another theme and see if your posts re-appear.

    If they do, something about your theme is incompatible with the newest version of WordPress.

    Yes that is a custom theme and talking to the author he stated that I need WP 2.7 or higher for it to work. Unfortunately I am having troubles upgrading. The dashboard tells me to upgrade (from 2.6.2), But when I do, I am told that I don’t need to. 🙁

    Changing themes does make the page work, but I would like to upgrade and use the custom theme. It is working on other peoples blogs.

    Dave

    I also tried upgrading from 2.6.2 to 2.6.5 ad I still get the same message that I do not need upgrading. Is there a list of files that have my settings and the posts that I could back up? And then I would delete the whole folder and start over with a clean install?

    I am new here – Is it always this slow getting help here or is everyone away for the holiday weekend?

    Hello?– Anybody got any ideas???

    You can try to disable your plugins and themes then upgrade your wordpress and enabled them

    I am sorry that I brought up the theme. I do not have any plug-ins. I am currently using the default theme. I can not upgrade as stated in my first post:

    ” My blog dashboard says that I should upgrade from 2.6.2 to 2.8.4, but when I do, it says that I am up to date and do not need to upgrade.”

    There is not any issue with a theme or plug-in – hence the thread title “Upgrading Issues”

    “I also tried upgrading from 2.6.2 to 2.6.5 ad I still get the same message that I do not need upgrading. Is there a list of files that have my settings and the posts that I could back up? And then I would delete the whole folder and start over with a clean install? “

    I appreciate the replies so far, but I don’t think this is an easy fix. I had this issue in the past and did not get it fixed. I just stayed with 2.6.2. I can’t stay with that version forever though.

    whooami

    (@whooami)

    Member

    if you like, drop me an email, ill do the upgrade for you.

    help.me.with.wordpress@gmail.com

    Well I found the extended upgrade instructions and all is fine now.

    Thanks for your interest.
    http://www.cavecountryweather.com/wordpress/

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Upgrading issue’ is closed to new replies.