[resolved] Upgrading I left plug-ins enabled by accident. Fatal error call? (9 posts)

  1. rawcarrot
    Posted 9 years ago #


    Being a retard, I left my plug-ins activated while uploading the new files for 2.0.5 and of course now I get a blank screen with an error message:

    Fatal error: Call to undefined function: wp_get_current_user() in /blah/blah/wp-includes/capabilities.php on line 312

    Now, I'm hoping there is a way for me to disable the plug-ins manually?

    Any ideas?

  2. moshu
    Posted 9 years ago #

    If you really need it, you can just go through FTP an delete them.

    Before that you could try to upload a fresh copy of the WP files - files get corrupted more often than you'd think; and see if it changes anything.
    Uploading a fresh copy does NOT require to run the upgrade script.

    EDIT. And only ONE post about the same question! Duoplicate posts get deleted.

  3. Chris_K
    Posted 9 years ago #

    FTP to the site and move 'em out of the wp-content/plugins directory.

    What version did you upgrade from?

    Did you run the wp-admin/upgrade.php file?

  4. rawcarrot
    Posted 9 years ago #

    2.0.1 -> 2.0.5

    Have tried reuploading the files. No joy.

    Tried running upgrade.php but got the same error message.

    Will now try moving the plugin files...

    Fingers crossed.

    Thanks for your help guys.

  5. rawcarrot
    Posted 9 years ago #

    No luck moving the plugins.

    Though I've taken a look in the pluggable-functions.php file to try and find the function:


    but the only function resembling it seems to be:


    Might try renaming the function... Fingers crossed.

  6. Chris_K
    Posted 9 years ago #

    Make sure you're updating ALL the files with the new release (perhaps reupload everything in wp-admin again).

    Make sure that your FTP client is set to move the PHP files in text or ascii mode.

  7. moshu
    Posted 9 years ago #

    Don't change, modify core files! It means the file was NOT uploaded correctly or completely.

  8. rawcarrot
    Posted 9 years ago #

    Ah... Decided against renaming the functions.

    Opted instead to delete the entire wp-includes folder.

    Then uploaded again the NEW files.

    Tried wp-admin/upgrade.php SUCCESS

    Restored the plugins folder.

    Tried wp-admin/upgrade.php again SUCCESS

    Just completed upgrade progress.

    After a very long pause...


    All seems to be fine.


    I noticed that in the wp-includes/ folder there is a "cache" file.

    Could it be that the 'new' WordPress gets confused by the 'old' cache file?


    Anyway. All fixed... I hope.

  9. Chris_K
    Posted 9 years ago #

    Excellent -- glad to hear you got it squared away.

Topic Closed

This topic has been closed to new replies.

About this Topic