Support » Installing WordPress » Upgrading from 2.3.3 to 2.5.1 (initial mysql db backup has been made)

  • Hi, this is the first time I have problems upgrading WordPress since my 6 months blogging. So, I was going to upgrade from 2.3.3 to 2.5.1. These were the steps that I took:

    1. Backup my blog database.
    2. Deleted all my files (of course, saving themes, plugins)- but, didn’t deactivate my plugins (I’m not sure if that should be my real problem).
    3. So the initial database was still online. Now, I upload by FTP the new version (2.5.1).
    I don’t get the “UPGRADE” button that people seem to talk about around here. It just asks me to install WordPress. I’ve installed it. I’ve tried to upload WordPress eXtended RSS or WXR file, but these kind of things are new to me. So I don’t have those files. The closer thing that I thought I had was the RSS import option, but I can’t do that either. The thing is I was used to only backup my database, nothing else.

    Ever since, I’ve tried surfing over the Internet, searching for a site that has wordpress 2.3.3 available for download, just to restore all my blog, just like it was before. I’ve found nothing.

    So, is there any way that I could restore my blog back, or I could get my blog upgraded to 2.5.1 if I have my previous 2.3.3. mysql db backup? I’m really desperate…
    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Did you save your wp-config.php file? That file tells WordPress where your database is. If you deleted it, you’ll need to recreate it with the correct information. Use the wp-config-sample.php file as a template. Once you create that file and put it on your site, it’ll stop asking you to install and tell you to upgrade the database instead.

    Note that if you did an install instead, you may have erased your old database and will need to restore your backup first.

    Also, all older versions of WordPress can be found here:

    I’ve uploaded the versions from the link above, one by one (2.3,2.3.1,2.3.2,2.3.3,2.5.1) leaving my initial database intact. Still nothing.
    When I’ve uploaded the 2.5.1 again, I hit wp-admin/upgrade.php where I get the UPGRADE buttton (“Your database is out of date”) and I get these errors ( ). I hit continue, I see that my blog is “installed” but no posts, categories, nothing. What can I do? Please…

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    You don’t need to incrementally upgrade.

    Stop doing strange and bizarre things.

    Restore your database from your backup.
    Put a fresh copy of 2.5.1 on there.
    Setup the wp-config.php file to point to your database.
    Let it upgrade normally.

    Done and done. Don’t try to do all sorts of weird stuff to fix the problem, just do it the right way in the first place.

    Hey, I appreciate all your help but what is it that you can’t understand? My last actions were:
    1. Import with my Phpadmin my previous database.
    2. Uploaded the 2.5.1 files with the correct db informations.

    How can I fix this? What is it that I am actually doing it wrong? And please, give me some more alternatives in case one isn’t working… I spend too much time on this forum refreshing the page just to see if I got a reply…

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    What I don’t understand is why you’re doing things like:

    I’ve uploaded the versions from the link above, one by one (2.3,2.3.1,2.3.2,2.3.3,2.5.1) leaving my initial database intact.

    You don’t need to do any of that, and your database is probably screwed up beyond repair at this point from everything you’ve done. If you did exactly what I said, restored the backup, tried the upgrade, and then are still getting those errors, then I cannot tell you how to fix your problem. If what you say is true, then your backup is broken.

    My advice is to get on the wp-pro mailing list and see if you can find a professional to fix it for you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Upgrading from 2.3.3 to 2.5.1 (initial mysql db backup has been made)’ is closed to new replies.