Support » Fixing WordPress » Upgrading from 2.0 to 2.0.1

Viewing 15 replies - 16 through 30 (of 94 total)
  • IMPORTANT NOTE for anyone using the Optimal Title Plugin.

    I had some problems with my blog at http://www.thecrmcoach.com/blog After running the upgrade program, all I got was a blank page!!

    After a few seconds of horor and hoping no one from digg was trying to dig me, I figured it out…

    First I check the error_log file in the root of my blog. That told me there was a problem with optimal_title() in my header file (I have a custom theme).

    Optimal_title is from a plugin which I had disabled. But, because it was disabled, it broke my page.

    I simply took the line out of my header file which let my page work fine. I then reactivated my plugins, put that line back in and presto! It works!

    Someone plz help me!!!
    I changed the required files as was posted by armadillo (thanks mate) but now I cant upgrade!!!
    when I run http://www.angry-indian.com/wp-admin/upgrade.php
    it says,
    Fatal error: Cannot redeclare check_admin_referer() (previously declared in /home/aindian/public_html/wp-includes/pluggable-functions.php:228) in /home/aindian/public_html/wp-admin/admin-functions.php on line 966[]

    Luckily, my site is still running…
    Please help ASAP…

    same problem as aindian…..

    Here’s my problem. Upgraded per Tamba’s instructions. The upgrade went smooth as silk.

    Then I edited an old post and hit “Save.” Instead of what I normally see, I get a PINK BAR with the post ID on its left-hand side, at the top of a white screen. I checked under Manage and my edits did save.

    I created a new private post and the same thing happened. This also happened on a friend’s blog (hosted on a subdomain) that I just upgraded to 2.01.

    What the heck’s going on?

    Me again. I can confirm that the PINK BAR posting problem also occurs when I try to publish a new Page.

    I had some trouble with saving posts… when I view source on post.php there was a section that looks like this:

    <input name="referredby" type="hidden" id="referredby" value="<div id='error'>
    <p class='wpdberror'><strong>WordPress database error:</strong> [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY post_id, meta_key' at line 1]
    SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN() ORDER BY post_id, meta_key
    </div>redo” />

    I tracked it to:

    url_to_postid($_SERVER['HTTP_REFERER'])

    This code from “edit-form-advanced.php” outputs the error. I’m not sure what it does, so I’m commenting out this part of the conditional statement. Everything seems to work fine now, but what is this functionality for? Is it broken or did I do something daft? 🙂

    I wanted to cry (not literally) when I saw the error of tanster (I use Adhesive plugin too).

    Thanks for mentioning it! Since the permalinks of my 2.0 installation suddenly stopped working, I was really decided to start again.

    And my permalinks work again now, I’m really glad =)

    Stahn, did you receive the same error message as I did when Adhesive is activated?

    2.0.1 does not work with mysql 3.x.x
    one of my blog http://phpbbcn.com lost all the entries 🙁

    but the other in mysql 4.1 works fine.

    On the side note: I know most do it, but disable ALL the plugins regardless…and yet still “keep the thought” in your mind that some plugins might NOT WORK with a new upgrade.

    Just becareful and if need be, keep certain plugins turned off.. until you get further notice of the “plugin maker”. =)

    Also, this upgrading is “scary” and I know how ya’ll feel. Believe me…the “blog” is your “lifeline”.. to a degree. The comments and replies from everyone, is a tool for others to learn from in a sense. =) So others might not make that same mistake as you did or visa versa!

    spencerp

    <sighs!> And still has to update mine..<worries>..but that is always normal lol..

    got problem with polish signs 🙁
    look at http://www.fanatyk.org 🙁
    whats wrong? I’ve done everything step by step with readme 🙁

    All’s well now. My posting problems (where after posting anything I’d see a pink bar across the top of an empty white screen) turned out to be plugin-related. It was caused by an older version of the GEO plugin, version 1.9. Owen must’ve changed the numbering scheme, because the lastest version that I downloaded from http://www.redalt.com/downloads/ is version 1.0.

    In any event, GEO version 1.0 is compatible with WordPress 2.01.

    So now I can say… nice, bug-fixin’ upgrade!

    @fanatyk: what is exactly incorrect with you polish characters. on my browser, everything seemed to be display ok. I also have a beta for my kontaktanzeige site which uses german symbols and have’t had any issues yet. P.S. Please also mention the build version you installed.

    I had problems with the Adhesive plugin activated, too. I had just 2 posts listed, with no text in them and filed under “uncategorized”. At first, I panicked then I turned off adhesive and all was well. Unfortunately I didn’t even get an error message, I just thought my DB had been corrupted. After disabling the plugin, everything works. Even uploading files via ecto. Thumbs up for the update!

    Hmmm, I think I’ll wait on the upgrade. The thing I’m worried about, and I think someone mentioned this, is if I have plug-ins that I have to disable but by disabling them it breaks my page. How do I get around this when doing an upgrade? I guess I could comment them out before doing the upgrade…

    I might try tonight if my internet at home decides to work.

Viewing 15 replies - 16 through 30 (of 94 total)
  • The topic ‘Upgrading from 2.0 to 2.0.1’ is closed to new replies.