Support » Installing WordPress » Upgrading from 1.5.x to 2.7 [the plan]

  • Hi there,
    I am currently running a website with WordPress 2.6.3 and one with a rather old WordPress version: 1.5.2

    I know, it’s been a while since this version became outdated, but here I am. I not only want to change to a newer WordPress version (namely 2.7), but also get rid of the tabled theme I made back then, so solve two problems in one swift.

    I’ve read all instructions on how to upgrade from 1.5.x to 2.6.3, but since I’ll be working on the theme and installing new plugins, that would mean sending the website into maintenance mode for at least a full week. Since that is not really an option for me, I’d like to setup a new (parallel) WordPress within an extra folder (i.e. domain.com/wp/) and get the theme and plugins ready, so that I can just swap the new WordPress into the old position and replace the old one. Of course I’d have to copy the database contents, insert those into a new one and simply make the necessary changes to the wp-config.php, where I will have to delete the DB_COLLATE and DB_CHARSET – as far as I understood this here correctly:
    http://codex.wordpress.org/Editing_wp-config.php#Database_collation

    So, does the plan sound reasonable? Is there anything else I have to take care of – besides making backups of both database and files?

    I’d appreciate any helping hand.

    Flashbytes

    PS: I’ve tried importing the online database into a local SQL database (using XAMPP), but due to a version incompability it didn’t work 🙁

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Upgrading from 1.5.x to 2.7 [the plan]’ is closed to new replies.