Support » How-To and Troubleshooting » upgraded to 3.5: now 'text' tab in editor does nothing

upgraded to 3.5: now 'text' tab in editor does nothing

  • I just upgraded a WP 3.4.2 to 3.5, and the plain text (HTML) editor is now unavailable, i.e. click on the ‘text’ tab does nothing (at least in latest FF on W-XP).
    No plugins, no custom stuff installed for the editor.

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi


    Forum Moderator

    thx for reply – yes I did go through that list 1st, but couldn’t find any clue. I think 3.5 is too broken or, the other way around, breaks too many things. I don’t have time to tackle the thing, so like others I downgraded to 3.4.2 and will remain with it till a 3.5.x which hopefully will address the issues.



    Forum Moderator

    I think 3.5 is too broken

    It’s working fine on my 13 sites. And on the vast majority of the other 5+ million sites using WordPress 3.5

    well, there was no offense or bad complaining intended of course, just matter of fact: others managing many sites have reported it worked on some sites but broke on some other, with no (clear) cue of the reason.
    And that’s my case too. It broke on 1st site I tried of those I manage, hence I’m not going to try on others till the dust settles.

    there might be some dependencies issues, that the WP installer doesn’t catch: if I try a distro pkg (on a CentOS 5.8 machine) it won’t install due to missing php53-simplepie which seems unavailable, yet the WP upgrade from dashboard would complete fine.



    Forum Moderator

    just matter of fact

    I didn’t mean to imply that this was a complaint but, if there really was such a bug in WordPress 3.5, then it would have been missed in the 5+ months of beta testing and we’d be swamped by reports on these forums. Since neither has happened, this would suggest that the problem is specific to your site. Try adding define('SCRIPT_DEBUG', true);to the bottom of your wp-config.php file (just before the require_once line).

    point is, it doesn’t work here as well as on other sites, and if the problem is site-specific (likely), install/upgrade script fails to detect it.
    I’ll try your instruction once I have the time to re-try the upgrade.

    I had the same problem and fixed it using the “Use Google Libraries” plugin. You can see all the details here.
    It worked for me, which was a relief !!
    I hope it will help you too.

    thanx for the hunch, on next try on that system I’ll keep your link handy

    btw, I upgraded on a backstage CentOS-5.8 server and it’s working

    neither 3.5.1 worked – got errors in FF’s console.
    But installing the “Use Google Libraries” plugin as suggested solved the problem(I’m seeing errors in console again – the ‘new features’ popup for e.g. gallery doesn’t go away clicking ‘dismiss’ :/ – reg jquery now, but at least this critical part seems working now).
    FF complains (sorry, it’s in IT partly):

    “Data e ora: 26/02/2013 11.20.44
    Errore: la dichiarazione XML o testuale non √® all’inizio di un’entit√†
    File sorgente: http://mysite.com/wp-admin/admin-ajax.php
    Riga: 4, Colonna: 1
    Codice sorgente:
    <?xml version=’1.0′ encoding=’UTF-8′ standalone=’yes’?><wp_ajax><response action=’autosave_22′><autosave id=’22’ position=’1′><response_data><![CDATA[Draft saved at 10:20:29 am.]]></response_data><supplemental><active-post-lock><![CDATA[1361874029:1]]></active-post-lock></supplemental></autosave></response></wp_ajax>”

    “Data e ora: 26/02/2013 11.29.13
    Errore: TypeError: a.curCSS is not a function
    File sorgente: https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js
    Riga: 366″
    “Data e ora: 26/02/2013 11.29.12
    Errore: TypeError: n._childConstructors is undefined
    File sorgente: http://ajax.googleapis.com/ajax/libs/jqueryui/1.9.2/jquery-ui.min.js
    Riga: 5″
    “Data e ora: 26/02/2013 11.29.11
    Errore: TypeError: e is undefined
    File sorgente: http://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js
    Riga: 2″

    Deactivating the Google Libs plugin, the dismiss-popup works, and now seems to work plaintext editor selector as well – I suspect some caching effect though, since the only js error I see now is:

    “Data e ora: 26/02/2013 11.31.30
    Errore: TypeError: e is undefined
    File sorgente: http://mysite.com/wp-includes/js/jquery/jquery.js?ver=1.8.3
    Riga: 2″

    I’ll play a bit more, flushing caches etc – eventually if I see a rule I’ll report and close the issue

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘upgraded to 3.5: now 'text' tab in editor does nothing’ is closed to new replies.