Support » Fixing WordPress » Upgraded to 3.5 – Database Update Fails

  • Resolved Dave333


    I successfully upgraded to 3.5 but have been locked out of my Admin area after a failed database update. After upgrading I was presented with a screen requiring me to update the database:

    Database Update Required

    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

    The update process may take a little while, so please be patient.

    and then a button:

    Update WordPress Database

    After clicking the button I am presented with a white screen with the WordPress logo on top. No matter how long I waited nothing more happens. It has hung. I’ve tried several times.

    So I have gone into phpMyAdmin and disabled all plugins. That hasn’t changed the situation as when I visit I am given the same instruction to upgrade the database.

    I’ve tried forcing the update of the database through phpMyAdmin by changing the db_version setting to 21707 as instructed in the Codex. But this then just takes me back to the suggestion to update my database and I am back at square one with the blank white screen with the WordPress logo at the top.

    Any ideas on how to get my database to upgrade without giving me the “WordPress White Screen of Death”?

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’ve solved the problem.

    It turns out that I should have changed the db_version setting to match 3.5, which is 22441 and NOT the previous version (21707) as instructed by the Codex.

    I don’t know if the Codex is therefor incorrect or if my situation is an isolated weird case. Perhaps someone else will find this information useful.

    I had the exact same issue.
    I ‘repaired’ the wp_options table within PHP MYSQL and it resolved ..

    This post just saved me big time. Thank you guys!

    Glad it helped Chairbeat.

    Does anyone know what the db_version setting for 3.5.1 is ? or where to find this detail please.



    Forum Moderator

    @jason – if you have a question, please start your own thread. It’s really not helpful to post in multiple old threads – they are not relevant to 3.5.1 anyway.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Upgraded to 3.5 – Database Update Fails’ is closed to new replies.