Support » Installing WordPress » Upgraded to 3.4.2, then lost a year's worth of posts and comments — Solution?

  • Resolved MisterIndigo

    (@misterindigo)


    Greetings, everyone! (I hope my fellow East Coasters are okay.)

    I updated my WordPress.com Popular Posts plug-in last night and lost a lot of stats, as if it went back a year. No clue why that happened. Then I upgraded WordPress today to version 3.4.2 and 14 months of posts and comments disappeared from my dashboard. Somehow I feel that these two events are related.

    Now the odd thing is, those posts and comments are still visible on my blog. I just can’t seem to access them through the dashboard.

    Can anyone tell me what went wrong and how I can fix this glitch short of having my hosting provider use a back-up from a day or two ago to revert to my pre-3.4.2 site?

    Thank you for your help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • have you tried to disable the plugin to see if that makes the posts show back in the dashboard? If that works there is a plugin issue. A backup however is not a bad idea to get 🙂

    If I disable the plugin, will it lose the info it still has? Thanks!

    Tried it, no change. Maybe I’ll go through the other plugins now.

    backup your site also before making too many changes here but it sounds like an issue just with the plugin and the version of WordPress. It might not be compatible.

    I wonder if there’s a way to install a past version? Thanks again.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Can I get a link to your site, so I can go look?

    So I discovered the source of the problem.

    My website programmer had built and customized my new WordPress template within my site but with a slightly different URL extension. Once we decided to go live with the finished product, he took that test version offline and used the redesign. For whatever reason, this new WordPress upgrade brought that early version back into public view (evidently it was never erased, not a good idea), so I had TWO separate sites up, the current one and the original test site, with just slightly different URLs.

    The reason the confusion occurred is that the comments needing approval coming into my inbox suddenly started linking to the old site and not the new one. Don’t know why that happened. Bizarre. I now wonder if that test version was never taken down after all.

    Thank you for your time! This is the weirdest WordPress situation I have ever come across.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Upgraded to 3.4.2, then lost a year's worth of posts and comments — Solution?’ is closed to new replies.