Support » Fixing WordPress » Upgraded to 3.4 Can't switch between editors or insert images or links.

  • Hi there. I’ve just upgraded my wordpress to 3.4 and now when I’m adding a post I can’t switch between the visual and html editors. And I also can’t insert links or images into the post. I can’t figure out what the problem is. Does anyone have an idea why?

    Any help is appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Can anyone help? I still can’t figure out what the problem is.



    We’re having a similar problem…my friend (working on site with me) cannot use visual mode because it runs off the screen, doesn’t wrap…so she uses html mode but just today it strips her links every time.

    Is this an issue that is happening because of the recent upgrades? Is there a solution?

    Hi Sevenisles, can you give a bit more info please? eg:

    • Have you disabled all of your plugins?
    • What browser are you using?
    • Have you tried going back to one of the default themes?

    You can try using a different browser, disabling plugins or using a default theme (TwentyTen or TwentyEleven) and see if any of that fixes the problem. Hopefully, this will narrow down possible causes.

    @tina, That doesn’t seem to be one of the issues I’m having.

    @raydale, I disabled the plugins, but that didn’t seem to do the trick. And I tried using both Safari and Firefox (both most current versions). Still not working. I didn’t try switching to a default theme yet. I would then have to redo my theme or create another one and was hoping not to just yet.

    I have another site that isn’t live yet and everything seems to be fine on that site once I upgraded. But it’s with a different hosting company. Could it be an issue with the version of .php the host is running?

    Thank you for replying by the way.

    Hmmm, Sevenisles, the php version causing the problem sounds like a strong possibility.

    Check the PHP version with your host (you should be on 5.2.4 or above to effectively run WordPress). Or, insall this plugin to check for yourself: WordPress phpinfo.



    I thought when you said that you couldn’t insert links that maybe it was also stripping your html, as it is with my friend. I apologize for misunderstanding.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Upgraded to 3.4 Can't switch between editors or insert images or links.’ is closed to new replies.