Support » Fixing WordPress » Upgraded to 3.2 Visual editor buttons missing

  • I upgraded to 3.2 from the last latest version and now when making a post / page the visual tab has NO controls. The visual tab still exists and the HTML still has the usual controls in the toolbar, but the Visual tab just simply has no toolbar .. nada.

    Tried a few fixes for this and nothing is working.

    Cleared browser cache and restarted / refreshed .. no dice.
    deactivated all plugins… no dice.
    Switched to default 2011 theme – no dice.

    Any suggestions? Not a problem for me to edit in HTML view, but HUGE problem for the blog’s other users.

    and yes, my host meets the minimal requirements

Viewing 15 replies - 31 through 45 (of 61 total)
  • install json for php , i do that and now everythings ok !

    HI AprilRobin,

    I’ve just fixed this problem on my blog and all seems to be working again.

    The Tiny MCE is looking for a file: wp-includes/js/tinymce/langs/en.js

    I just checked the file and on my installation the file path is this: wp-includes/js/tinymce/langs/wp-langs-en.js

    I deleted the ‘wp-langs-‘ part of the file name ‘wp-langs-en.js’ and I seem to be working again.

    Let me know if this works for you.

    I had a great guy tell me this:

    Download CKEditor. It works. I have a new and improved visual editor!

    And I am a zero code efficient girl.

    NextGen Gallery appears to be causing an issue for me on a few sites. Disabling it brought back the visual editor.

    Corretion – I think it is actually to do with my serving static files from a different domain.



    Tried everything suggested here, but nothing worked. Removed 3.2 and reinstalled 3.2 and now the visual editor is back. just to see if it is an issue with the upgrade I’ll install 3.14 and then try the upgrade again.

    timchorlton – tried your suggestion on a new install of 3.2 and did not have success.

    I started a new thread as my issue was not due to an upgrade – but verified the upgrade did not work as well (new install of 3.1.4 worked but failed once upgraded to 3.2)

    My post



    OK – The upgrade from 3.14 to 3.2 worked this time, actually twice – once with no plugins and once with all the plugins installed. That was on one site. So I thought maybe the reason for the issue with the visual editor to transitioning the upgrade properly might have been due to a plugin that hadn’t been upgraded.

    I tried the upgrade on another site with all of the same plugins as the first site and all the latest versions of plugins. The upgrade worked. I tried the upgrade on a third site and again all plugins the latest version, this time the upgrade caused the same issue and it no longer has a visual editor.

    Back to square one – looking for a pattern if there is one. Each site has a different theme but each site had the same plugins.

    I also had the problem of the visual editor buttons vanishing and white text in the edit area after the upgrading to 3.2 – and I noticed a couple of other issues:

    – the arrows on the buttons in the widget area had disappeared.

    – Some of my sidebar plugins failed to work on individual posts and pages (although they worked on the front page and category pages).

    I was about to follow the advice given earlier and do a manual install. But before doing so, I re-installed the 3.2 update and all the problems went away.

    It maybe worth reinstalling the update again to see if it resolves the issues before going through the lengthy process of manually reinstalling.



    If I rename the wp-includes folder and then upload the folder and all files in it, the issue is fixed. Haven’t figured out why or what file in the wp-includes folder was missing or corrupted and causing the issue though.

    OK, I’ve found the solution to the problem.

    You have to change permissions (chmod) if you can.

    By default some files get de 600 permission when you update WordPress to 3.2
    You have to change it to 644.

    What files? Well, I’ve found quite a few in these folders:

    Remeber to empty all caches (browser included) after the change of the permissions.

    Sorry for my bad english 🙂

    I’m having a similar issue, although I do see the buttons and all, the visual editor text box appears as the HTML one, so I’m not getting visual editing at all.

    I’m guessing my issue pertains to what has been discussed in this thread.

    Ever since upgrading to WordPress 3.2, the Visual Editor does not work for Pages and Posts on one of my sites. Also the Admin Bar does not appear on the Post/Page Edit pages. To try to fix the problem I have done everything mentioned on this thread:

    The site with the trouble is using mySql 5.0.90 and PHP Version 5.2.12. However everything works fine on my local dev site with exactly the same plugins and theme where I am using MySql 5.5.11 and PHP Version 5.2.9

    I have deactivated all plugins.

    I have un-installed some mu-plugins.

    I have reinstalled 3.2 automatically and manually.

    I have checked all permissions for files in the root folder, wp-admin and wp-include folders and they are all correct.

    I have changed the theme to TwentyTen and TwentyEleven.

    I have emptied my cache each time after making a modification.

    And I have tried numerous other solutions suggested.
    There are some screenshots here, so you can see exactly what I mean.
    I would really like to solve this. I am very conscientious about upgrading wordpress and upgrade all my sites at every version. This is the first time I have had a major problem.

    We’ve just had this problem with a client’s site. On looking through the source code I found that the JavaScript for TinyMCE and other scripts wasn’t loading. Compared to my own blog, which is fine, this should be in the footer. On my client’s site the source code stopped with a closing div instead of finishing the page.

    Whether this is down to the sensitivity settings for PHP errors/warnings I’m not sure. Unfortunately we can’t find an error log at present so we don’t know what the actual error/warning is (maybe someone can check their error log if they find they have the same problem?).

    Anyway, for us, our fix was to open up wp-admin/admin-footer.php and comment out line 36

    do_action(‘admin_footer’, ”);

    Hope this helps someone.

    Okie Dokie.

    The above suggestion worked. I commented out do_action('admin_footer', ''); in wp-admin/admin-footer and it fixed the problem.

    thank you very much.

    I am not sure but this seems like a “bug” to me, since I have to alter the “core”. I don’t really know how to report to the WordPress devs. If anyone know please tell me. Thanks.

    And I wanted to say, “Thank You Very Much” again, since this was a difficult problem to solve.

    I was having the same problem. Deleting my browser cache/temporary files solved the problem for me. Hurray!!!!

Viewing 15 replies - 31 through 45 (of 61 total)
  • The topic ‘Upgraded to 3.2 Visual editor buttons missing’ is closed to new replies.