Support » Installation » Upgraded to 3.1, Now my Permalinks Dont work!

Upgraded to 3.1, Now my Permalinks Dont work!

  • Hey guys hope one of you can save the day. i just updated wordpress on my site and now all my news links are broken and redirecting to my index page.

    My category pages are also doing the exact same thing. I tried going into my admin and hitting the permalinks button again but im still fubar.


Viewing 15 replies - 31 through 45 (of 81 total)
  • Ok, for all you doubters – I did a totally fresh install on one of our test servers.


    Hanging, looping on the front end, I can get in to the admin.

    This is a brand new install of 3.1 that I downloaded this morning, on a windows machine.


    In one of my sites it was the Simple Tags Plugin.

    Hmm, so there are obviously other plugins/themes that might contribute to the problem – but, one general note. I did not get my install working even after removing ALL of the plugins until I went in and completely flushed my .htaccess and resaved the permalink structure. I’d remove everything and do that purge, then make sure it is working before proceeding. If you purge everything and it still doesn’t work, it’s probably your theme – try switching to the default theme.

    I’m working of a totally fresh install… so I didn’t modify it one bit. Are you saying it is the 2010 theme that came with the fresh install, in a totally fresh directory with a totally fresh domain name? :-\

    +1 quicoto. It was the same for me too: SimpleTags!

    yep it looks like SimpleTags can’t handle the 3.1 upgrade. Disable it and the category links will work again.

    If your site is hosted on godaddy simply go to Hosting > Content > File Managar and click on your wordpress folder. Restore to the previos day. everything back to 3.0.x

    worked for me at http://orioles-nation.com/

    @docarzt – genius!

    Took two tries, but it took the second time. I don’t understand what was causing a ‘delay’ in it.

    When I disabled the plugin, all my posts were still broken, and then seemed to right themselves a minute or two later.

    Then after commenting out that dumb flush_rules() line, I reactivated the plugin… and it was broke again. So I deactivated (again), waited a minute (again), then reactivated (again).

    Everything is back to normal now. Anyone know why WP wasnt keeping up? (cache was disabled the whole time)


    My guess, seriously, would be browser cache.

    *shrugs* Do know it was not that. I was clearing in FF, IE8, and Chrome, and getting the same result. Just glad its fixed!

    OK had the same problems on my site MyGreatPhone.com with permalinks setup with /%category%/%postname%/

    I fixed by finding any plugins which made changes to permalinks, in my case it was the multipage toolkit.

    I disabled that and THEN went into permalinks and reset it so that the permalinks htaccess was rebuilt.

    You must disable plugins first and then rebuild permalinks.

    All is working now.

    Across the net other plugins are being reported as the culprit, something to do with how 3.1 handles cats, if you have this issue, and want the quickest fix, disable all plugins THEN rebuild permalinks (i changed rule, and then changed back just to make sure), and then go through them one by one reactivating to find the culprit.

    I have dissabled Simple Tags and it works, the problem now is that I can’t edit (publish) anything!!!!

    Please, HELP!!

    I’m having a problem contributors and editors getting access to backend (Admin is ok).

    It’s definitely the permalink structure that is causing the problem. We’ve set it as custom ‘/%category%/%postname%/’. However this is breaking the backend for our editor and contributor users (Admin access is ok).

    The custom url structure is causing the problem. When we set it as ‘http://www.webgrowth.biz/2011/02/sample-post/’ there is no problem with editor or contributor backend access.

    We unfortunately cannot afford to change the url structure as we have over 140 posts that will need redirecting. These posts also have retweets and facebook likes, which affects our authority.

    We’ve tried de-activiting the plugins, re-saving the permalink structure and then re-activiting custom permalink structure. It didn’t work……

    Does anyone know how we can fix this issue by still keeping our custom url?

    I’ve written more about the problem in this thread, http://wordpress.org/support/topic/cannot-login-to-wp-admin-5?replies=9#post-1960265


    I’m having 404 issues as well after the 3.1 update (note to self, DO NOT UPGRADE UNTIL ALL IMPORTANT PLUG-INS ISSUE UPDATES AS WELL)…

    All my permalinks don’t work anymore ( ‘/%category%/%postname%/’ ) but works fine when reverted to the ?=123 default.

    I’m using Dean’s Permalink Migration and it couldn’t redirect the default permalink structure to the custom permalink anymore.

    My site relies on a lot of incoming links from forums and other organic sources so if their hyperlinks (using the ‘/%category%/%postname%/’ format) doesn’t work, my site wouldn’t get much traffic.

    My site has been working fine for 2+ years, and now it’s down due to this update grr.

    Please help if you can. I’ve tried creating a new htaccess after disabling all plug-ins, no luck. The only time it’ll work is when I reverted the permalink to the default.

    My site is http://reviews.davidleetong.com thank you


Viewing 15 replies - 31 through 45 (of 81 total)
  • The topic ‘Upgraded to 3.1, Now my Permalinks Dont work!’ is closed to new replies.