WordPress.org

Support

Support » Installation » Upgraded to 3.1, Now my Permalinks Dont work!

Upgraded to 3.1, Now my Permalinks Dont work!

  • Hey guys hope one of you can save the day. i just updated wordpress on my site and now all my news links are broken and redirecting to my index page.

    My category pages are also doing the exact same thing. I tried going into my admin and hitting the permalinks button again but im still fubar.

    Help?

Viewing 15 replies - 16 through 30 (of 81 total)
  • that’s not it for me. For one, I’m not using that plugin and beside that I already tried deactivating all plugins, switching themes, etc, but nothing worked

    Sadly, I think this is it for me. I really believe eventually WordPress will be a real CMS, but I’m tired of going into emergency mode everytime they update the script. My next dev cycle is definitely pointed at Drupal …

    sorry to hear that :(. I to disabled all my themes, switched settings, etc. But it was definitely the plugin that did me in it seems.

    just as a heads up my category pages are completely fubared still even after doing this.

    http://www.moviesonline.ca/horror-movies/ 🙁

    http://www.moviesonline.ca/category/horror-movies/ 🙁

    I seem to have narrowed it down by deleting (not just disabling) the Multi-page toolkit. Posts fortunately work, so Google likes me again, but categories are still broken

    ooohhh yeah! it is now completely fixed, I feel so relieved..

    After disabling and then deleting the Multipage Toolkit the posts worked, but the categories were still being screwed-up by the workaround I had in place with the Advanced Permalinks plugin. Resetting and deleting that fixed it altogether.

    Awesome.

    So: if you’re having trouble with your permalinks after the 3.1 update, make sure to narrow down the problem by deleting plugins that might affect your permalinks (such as category plugins, this multipage thingy, or anything else related to it)

    Hope everyone gets it to work, because this new update is actually pretty sweet

    im gonna try deleting my top level categories plugin and re-installing it.

    deleting the plugin did not resolve my category pages not working. Everything else seems to work ok but not category pages. They are as you say fubard.

    Guys, I can confirm that there is no problem with this on a stock install. I’ve tested it multiple ways, and %category% works fine.

    You must have plugins or themes or some kind of custom code that is interfering or incompatible. There is no problem with a %category% in the permalink string on a base install.

    Hopefully this helps the rest of you fix this. I too ran into the permlink issue after I upgraded to 3.1.

    I changed my wordpress url and site url to have a / after the domain such as: http://www.site.com/ when I saved that it removed the / after the domain, but now my permlink problem has disappeared.

    I can confirm a couple of things that seem to help.

    1) Multi-page toolkit is TOXIC. You don’t have to delete it, though. Just disable it then change your permalink to default, save, then back to custom.

    2) I add this in as a last resort because it is a step that I used, although I suspect it is unnecessary: clear .htaccess completely and then save your redirect structure again.

    GOOD NEWS!

    Here is the permanent fix for this. The problem IS caused by the plugin Multipage Toolkit (Current version 2.6). The good news is, it can EASILY be fixed. For those interested in the how and why, here it goes:

    In the multipage toolkit folder in wp-content/plugins open TA_multi_toolkit.php and observe:

    add_action('init', 'allpage_permalink', -1);
    function allpage_permalink() {
    	global $wp_rewrite;
    	$wp_rewrite->add_endpoint("all", EP_ALL);
    	$wp_rewrite->flush_rules();

    You will find this block of code at line 332. When the plugin is initialized it will flush the rules. For whatever reason, it got away with this on earlier versions of WordPress – beginning with 3.1, this will obliterate certain custom structures (but, interestingly, not all).

    The easiest fix if you want to have custom Permalinks AND use Multi-page toolkit is to to remove the line:

    $wp_rewrite->flush_rules();

    From TA_multi_toolkit.php – the plugin does not need it to function normally.

    @docarzt i dont have that plugin and still not working for me.

    I getting crazy.

    I tryied to de-activate plugins, change permalinks…

    Sometimes works sometimes not.

    One thing is sure: default permalinks works.

    add_action('init', 'allpage_permalink', -1);
    function allpage_permalink() {
    ...
    	$wp_rewrite->flush_rules();

    *headdesk*

    People, this is just bad, bad, super-incredibly bad, code.

    If you have any themes or plugins doing flush_rules on every single page load, then your site is probably slow as hell. Disable those plugins, ASAP.

    MikeMovies –

    Top Level Categories plugin – So: if you’re having trouble with your permalinks after the 3.1 update, make sure to narrow down the problem by deleting plugins that might affect your permalinks (such as category plugins, this multipage thingy, or anything else related to it)

    Docarzt-

    Here is the permanent fix for this. The problem IS caused by the plugin Multipage Toolkit (Current version 2.6).

    I didn’t have any such related plug-ins and two of my sites, one of which was a pretty fresh install (no plug in and just a modified 2010 child theme), both tanked.

    Then I went in and did a TOTAL FROM SCRATCH install of the new 3.1 and I had the SAME EXACT ISSUES.

Viewing 15 replies - 16 through 30 (of 81 total)
  • The topic ‘Upgraded to 3.1, Now my Permalinks Dont work!’ is closed to new replies.
Skip to toolbar