Support » Fixing WordPress » Upgraded to 3.0; can’t access widget settings

Viewing 15 replies - 1 through 15 (of 16 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    increasing the available memory?

    – reviewing

    I just tried all those and reviewed the 3.0 Issues, Problems, Resolutions Thread. Still no change; I continue to lack access to the widget settings, oi!

    I’m guessing this might point to some kind of file permissions problem. FWIW, I’m hosting with NearlyFreeSpeech.NET. Just now, I ran into this guide to get WordPress playing nicely on NFSN and followed it. Now it appears it is playing a bit more nicely (non-manual plugin upgrades, finally!), but I’m still getting the nonsufficient permissions message trying to access the widgets page. And no link in the menu, either.

    I am experiencing the same problem. Does anyone already figured out how to fix it. Thanks in advance.

    Additionally, when I directly type the url of the widgets page: http://mydomainname/wp-admin/widgets.php, it gives me this message:

    You do not have sufficient permissions to access this page.

    I tried deactivating the plugins and even remove them. I try activating the default theme. I even deleted all files on the site and uploaded the freshly extracted 3.0 version via FTP but still encountered this…

    Yahoo I solved it! It turns out that my wordpress database upgrade doesn’t successfully completed. I needed to force upgrade it using phpmyadmin > browse the wp_options table > look for the record whose “option_name” = “db_version” and set its value to “12329” (if your previous version is 2.9.2. if you have different source version then you should change this to that version’s corresponding db_version.

    Then if you login again on the admin page it will ask you to upgrade your database. Just continue with the upgrade and you’ll be able to view the missing menus now. Enjoy 🙂

    Hmmm. Glad that worked for you. Unfortunately, I changed the value for db_version, went through the upgrade pages, and still have no widget settings access.

    Ahhhhh bug bug bug!

    I know The Codex says not to bump, but it’s been almost a week. Sorry, bump.

    I’m having the same problem. I also can’t access Authors and Users.

    Hate to bump, but I’ve been having this problem.

    I’ve deactivated *every* plugin, retinstalled WordPress, loaded the default 3.0 theme, loaded a different theme, checked my WordPress memory etc.

    It all seems to boil down to permissions. Now, I’m using a custom user and meta table as defined by:
    define(‘CUSTOM_USER_TABLE’, ‘blog_users’);
    define(‘CUSTOM_USER_META_TABLE’, ‘blog_usermeta’);

    Is this the root of my problems perhaps?

    Ding! I’m using a custom user role, too. I shall investigate and report anything I find. Thanks for the report.

    Aha, sounds like we’ve stumbled on the problem.

    This sounds like it’s really low-down in WordPress…
    Anybody got a clue how to get this working or a safe way of getting rid of these custom tables defines? (they drive me nuts anyway…)

    Well, I fixed my installation. Finally!

    Here’s how I think you can fix yours. As always, it’s recommended to backup your files and database.

    First, I don’t know if it makes a difference, but it may be a good idea to log out of WordPress.

    Also, before you do this, you may want to note down the settings for your custom user roles or whatever that is you’re talking about, as this will obliterate any custom user roles.

    Go into phpMyAdmin. Go into your WordPress database. Go to the search tab and look for ‘roles’ (make sure to select all tables, so you can search them). You’ll find the option_name wp_user_roles (you could have gone there directly, but I find it easier to search). Click the edit button. Replace the option_value with the following:


    Click Go right below that. Now, for good measure, go back to the front of your database, go into wp_usermeta. Find your username id # by referencing it against your nickname. Now find the wp_capabilities entry with that user_id and edit it. Put in


    for the meta_value. Click Go. [This part of the process I found out from here, though note the meta_value value they use is different.]

    Why does this fix it? New capabilities were introduced in WP 3.0, I found out via this wiki entry. Somehow, it appears, custom user roles got screwed over because of this.

    Anyhow, so reset the user roles by following the instructions I wrote above and you should be good to go, have all your admin powers back. Make sure to check up on and other users you have (if you have any) after the whole thing to see if you need to change their role or anything.

    Also, I don’t know if custom user role plugins work properly with 3.0 yet, then. I don’t want to test for a bit, at least! Anybody braver right now, feel free to report.

    Aaaaand one more thing. The problem was somewhat caused by a custom role plugin, but one might think WordPress would gracefully handle adding new capabilities to the correct role or whatever. Anyway, not good. Bug report, then?

    I have a question since I have the same/similar problem. I only have one user, admin user, and when I login to wp in the dashboard I have no menus at all. When I tried a direct link to let’s say widgets it reported that I have no authorization.

    From your post I am not sure if you changed something for admin user or for custom user?

    I actually didn’t have a role called ‘Administrator’ anymore (Grand Admin, rather…). So I changed stuff in the role description and also what my role was. Kind of resetting both with WP 3.0 values, if that makes sense.

    Sorry for the late reply, I wish there were email notifications here.

    Edit: just added this thread as a favorite and pulled it into Google Reader. I’ll keep up to speed now.

    Many many many thanks to wkor for the guidance.

    This wasn’t that simple for me!

    For starters, everything was never working because I had a WP_Object cache running, so any changes were still in memory – DOH!

    Eventually, after copying my custom user and usermeta table to where they *should* be, deleting the lines from wp-config.php and destroying the heck out of the custom tables to make sure they weren’t being used at all (I backed up… a lot)…

    I changed the {blog}_options table to have the new capabilities (*sniff* my custom capabilities gone – worth the sacrifice since they were a mess though).

    Then made a new admin and made that admin modify my other admins to be administrators (yeh, it’s stupid, but I’ve been having major problems getting my admins to log in again).

    Anyway, follow wkor’s advice with some slow careful steps, making sure you back-everything-the-heck-up. I was at it for a solid 2 hours with my admin account not being able to log in, having to make more accounts, modifying files in the admin to let myself temporarily back in… I’m over the moon my website is now normal and not a massive hack again. No custom tables. Nada. No hacks. All in one prefix. Beautiful.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Upgraded to 3.0; can’t access widget settings’ is closed to new replies.