WordPress.org

Forums

Upgraded to 2.7 - Blank Page (26 posts)

  1. octoberasian
    Member
    Posted 6 years ago #

    I followed all instructions on upgrading from 2.6.5 to 2.7 here on WordPress.org.

    I've already made backups of the directories, files and database.

    After the upgrade was complete, I am presented with a blank page of my website.

    I have already tried the following suggested in FAQs here:
    - Disable the plugins manually in phpMyAdmin
    - Switch to "default" theme manually in phpMyAdmin
    - Change the security keys

    My website is here

    What could have gone wrong?

  2. bludude
    Member
    Posted 6 years ago #

    I have the same problem- But everything in the admin area works fine. Just the site is blank. Even the default theme.

  3. whooami
    Member
    Posted 6 years ago #

    white aka blank pages mean there was a fatal PHP error. what do your error logs say?

  4. octoberasian
    Member
    Posted 6 years ago #

    How do I check PHP error logs?

    I'm on Yahoo Small Business Web Hosting.

    I know how to do it on my home server, but the blog isn't installed there.

  5. whooami
    Member
    Posted 6 years ago #

    Im not even sure yahoo makes error logs available, I cant remember. If they do, you are probably going to find them in their control panel somewhere? I wish I could help more, but if you know how to find them on your server, than at least you will recognize them when/if you see them there.

    Also, double check that they dont have PHP set up to write to an error_log in the same directory as where the error occurred. If they do, you'll find error_logs mixed among your files when you use an ftp client.

  6. octoberasian
    Member
    Posted 6 years ago #

    Got the log!

    Had to check Yahoo's Help Support section.

    Clearing the script and reloading my website, I get this single line:

    [12-Dec-2008 00:18:37] PHP Fatal error: Call to undefined function: wp_remote_post() in /aselin/wp-includes/cron.php on line 201

  7. octoberasian
    Member
    Posted 6 years ago #


  8. octoberasian
    Member
    Posted 6 years ago #


  9. octoberasian
    Member
    Posted 6 years ago #

    Sorry for the multiple posts.

    Apparently the WP forum didn't show my reply for some reason.

  10. whooami
    Member
    Posted 6 years ago #

    ok, that function is defined inside wp-includes/http.php

    do you have that uploaded?

  11. octoberasian
    Member
    Posted 6 years ago #

    Yes I have that uploaded and re-uploaded.

    After opening the http.php file in Dreamweaver, there is a function as "wp_remote_post()".

    Edit: There is a function called wp_remote_post()

  12. octoberasian
    Member
    Posted 6 years ago #

    Here's the function:

    function wp_remote_post($url, $args = array()) {
    	$objFetchSite = _wp_http_get_object();
    	return $objFetchSite->post($url, $args);
    }
  13. whooami
    Member
    Posted 6 years ago #

    dont upload with dreamweaver, if you are.

    upload the file with an ftp client, in ascii mode. :)

  14. octoberasian
    Member
    Posted 6 years ago #

    I'm using Filezilla set to Auto.

    I don't use Dreamweaver anymore for uploads for over two years now. ^^;

  15. Henry Jennings
    Member
    Posted 6 years ago #

    Just cleared the same problem from oneof my blogs; I renamed wp-print and wp-sticky plugins and voila, all was well again.

    Also, for people having problems seeing stuff on the dashboard, GET RID OF the plugin for dashboard menu drop downs; it destroys the menus. Boy was I scratching my head for a while. LOL

  16. octoberasian
    Member
    Posted 6 years ago #

    I cleared the plugins folder and manually cleared the active plugins row in phpMyAdmin. Still the same error.

    Uploading it via ASCII in Filezilla, still gives me a blank page.

    [12-Dec-2008 00:18:37] PHP Fatal error: Call to undefined function: wp_remote_post() in /aselin/wp-includes/cron.php on line 201
    [12-Dec-2008 00:25:15] PHP Fatal error: Call to undefined function: wp_remote_post() in /aselin/wp-includes/cron.php on line 201
    [12-Dec-2008 00:27:50] PHP Fatal error: Call to undefined function: wp_remote_post() in /aselin/wp-includes/cron.php on line 201
    [12-Dec-2008 00:28:04] PHP Fatal error: Call to undefined function: wp_remote_request() in /aselin/wp-includes/update.php on line 58
    [12-Dec-2008 00:38:14] PHP Fatal error: Call to undefined function: wp_remote_post() in /aselin/wp-includes/cron.php on line 201
    [12-Dec-2008 00:39:48] PHP Fatal error: Call to undefined function: wp_remote_post() in /aselin/wp-includes/cron.php on line 201

  17. octoberasian
    Member
    Posted 6 years ago #

    It could be sloppy programming or something, but a friend over MSN gave me a hint:
    "it is saying it is there but does not understand the function"

    I then remembered something back when I heavily programmed in PHP one function: "include ("xxxxxxx.xxxx");"

    I edited cron.php and added:
    include("http.php");

    This was added right below "<?php".

    Apparently, it seems that WordPress was calling for a function that does not exist. The file "cron.php" was asking for a function from another file, but that other file has not been loaded, or included.

    Hopefully, version 2.7.1 will be released to fix this.

    Now that the website is back up and running, I have no posts... >_>;

  18. Lillan
    Member
    Posted 6 years ago #

    I had the same problem and i solved it this way, first I had to overwrite the whole diectory wp-includes TWICE and after that all files in the root directory and then voila┬┤. I belive this must be a bug - or?

  19. khena25
    Member
    Posted 6 years ago #

    Lillian, can you please be a little bit more specific with your explanation. Sorry, but I don't get it. If it worked, can you show me please?

  20. rforster
    Member
    Posted 6 years ago #

    I just upgraded and got the same error. Using Filezilla:
    Had deleted the includes. Uploaded. Again as overwrite. Changed that line in cron.php. changed all the files in root.

    Now getting an error in compat.php but refers to wp-settings on line 207

    I did a download of my entire public_html directory. Revert and wait for a new version or am I getting close?

  21. rforster
    Member
    Posted 6 years ago #

    Made a mistake or two.
    I had uploaded includes to a subdirectory which caused that other error.

    I also had edited wp-cron in the root with what was in that other post. The real file to update is cron.php in the includes directory.

    My admin page login just gave me:
    Database Upgrade Required

    "Your WordPress database is out-of-date, and must be upgraded before you can continue."

    Will post back if things go bad.

  22. keithc
    Member
    Posted 6 years ago #

    Hi all,
    I had the same problem, blank page, so I modified the cron.php file by placing include("http.php"); as suggested by octoberasian.
    No luck, I recieved a Fatal error about declaring the http class twice.

    After removing this line and uploading cron.php one more time, I had to correct the image urls in my posts but now everything is viewable.

    Hopefully this helps.
    Keith

  23. gbolger
    Member
    Posted 6 years ago #

    Like the above I have the same problem
    I have one slightly different modification which is I am using multiblog which I upgraded before the upgrade to WP2.7, either way get blank screen. I can access my admin files by doing http://www.xxx.yyy/wp-admin/ but makes no difference.

    I have tried everything listed to no avail.

    Like other I await 2.7.1 urgently

    Gerry

  24. extrakun
    Member
    Posted 6 years ago #

    You have to upload the new files from the wordpress root folder as well (index.php, wp-app.php and etc.), taking care not to delete or overwrite wp-config.php (which is quite unlikely).

  25. senator94
    Member
    Posted 6 years ago #

    Solution....

    I had the same problem. I had to FTP into my plug-in directory and rename WP-Sticky folder.

    It worked perfectly.

  26. dreiecon
    Member
    Posted 6 years ago #

    I've had the same issue, and now I've managed to fix it, don't know what else is wrong though, it all seems to be working.

    Ok guys, here's a fix I used.

    EDIT cron.php

    Find
    <?php

    Add After;
    if(!function_exists("wp_remote_post")){
    require("http.php");
    }

    Save (Cron is fixed)

    EDIT update.php

    Find
    <?php

    Add After;
    if(!function_exists("wp_remote_post")){
    require("http.php");
    }

    This has fixed it for me.

  27. tiendx2002
    Member
    Posted 6 years ago #

    http://wordpress.org/support/topic/225345?replies=3#post-930668 this solution works better for me. Follow dreiecon first but that won't work for rss and so on.
    Thanks.

  28. gbolger
    Member
    Posted 6 years ago #

    Everyone, I'm back running again and basically uploaded a fresh (after several of the night builds) and also ensured I copied ALL the files into the root directory, and it worked a dream.

  29. jostubbs
    Member
    Posted 6 years ago #

    I had this message also. To fix the problem I uploaded the PHP files in the root wordpress directory, being careful not to effect wp-config.php.

Topic Closed

This topic has been closed to new replies.

About this Topic