Support » Fixing WordPress » Upgraded to 2.6.2: you don’t have permission error

  • I just upgraded to 2.6.2 on my blog.

    My posts seem to work fine (including editing), but I also have 6 pages. I can edit every single one of them now, except one. When I try to edit that one (I have even tried just opening it and clicking save), I get this error:

    Firefox:
    You don’t have permission to access /wp-admin/page.php on this server.

    Internet Explorer:
    You might not have permission to view this directory or page using the credentials you supplied. HTTP Error 403 – Forbidden

    I read about others having similar issues and they discussed .htaccess, but just to see if that was an issue, I deleted the entire file, but am still having the same problem.

    Does anyone have any ideas? I’m at a complete loss. My user/password did not change. I am at the same host, and so on. The only thing that changed is I upgraded last week to 2.6.2.

    Also, editing a post doesn’t seem to be an issue either, I tried editing several (just by opening and clicking save).

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • I found the solution!!

    Since I noticed that a number of these same questions went unanswered on this forum, hopefully this information will help if you are running into the same issue:

    Kinda sounds like a mod_security issue. If so, whooami’s oft-repeated advice follows:

    IF YOU DO NOT HAVE an .htaccess in your wp-admin/ directory:

    create a text file on your desktop:

    put the following inside it:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    save the file. name it whatever you want

    Upload the file to your wp-admin directory.

    Rename the uploaded file to .htaccess (with the .)

    IF YOU DO HAVE an .htaccess in your wp-admin/ directory:

    Edit it, and add the following:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    save the new .htaccess

    Here’s the original thread:
    http://wordpress.org/support/topic/132667?replies=30#post-610645

    Thank You jrober8, I am taking care of this issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Upgraded to 2.6.2: you don’t have permission error’ is closed to new replies.