Support » Fixing WordPress » upgraded to 2.6 and lost my rights as admin?

  • Resolved nobodywho


    so, this the story of my past 4 days:
    i was happily running a 2.5 at, then one day decided to upgrade to 2.6 so that the message on top of my dashboard would stop appearing (upgrade to 2.6).
    i was naive. i thought i’d just go to my dreamhost account and use theirs one-click-install button…oh dear.
    It did upgrade. when i went back on my dashboard a message came up to “finalize upgrade” or something, i clicked and it said a new password was sent to my email addrss …???
    i entered the new password and ta-taa i had a brand NEW 2.6 blog, with my heading on it, answering to my old url but two years of work disappeared in a big cloud of bytes..
    eventually after two days of agonizing through forums and help pages i worked out how to get the theme back to what it was and the mysql database to speak to wordpress. only now i am locked out of the dashboard all-together.. “You do not have sufficient permissions to access this page” it says now.
    i tried to set a new password, that didnt work.

    since then i had a good read at the amount of work i was meant to do before upgrading (back-up, delete files, save wp.config, de-activate the plug-ins n so forth) which i didnt (apart from a recent-enough back-up) now thou i cannot get in the nuts and bolts of the blog (apart from my FTP and my MySql files) so no chance of doin anything with the plug-ins or check the privileges of my admin log-in.
    i kept away from making noise ’till now, and in the past i resolved issues out of my own stubborn-ness. (see my thread here)
    but hey, this one is just taking me over the hill.
    is it anything to do with the SECRET_KEY in wp-config.php?
    at this stage i dont want to dig myself any deeper…
    anyone knows how to switch the light back on in here?

Viewing 10 replies - 1 through 10 (of 10 total)
  • “You do not have sufficient permissions to access this page”

    That sounds more like a CHMOD thing to me than a WP thing.

    Did you check your database to see if the old tables are still there? It seems like your installation was regarded as new so new tables were made which are of course empty. You didn’t do anything with the database yourself during upgrading? Such as making a new one? Any changes made in the wp-config file?

    Oh, and about that other thing, see the sticky. You’ll have to be working in the control panel and databases anyway, so…

    Thanks for your reply Gangleri, i will have to do some research re:chmod, at this stage i dont know what it is.
    The old tables are still there, as i managed to get WP to speak to mysql databse, by telling wp-config where to find them, and it worked. But as soon as i did that i was shut away from admin, my password not letting me thru the WP dashboard anymore.
    Now, as far as i know, wp-config is only meant to deal with the database, directing enquires to where it is stored (my mysql) so i cannot understand while it would upset so much the whole system, to the point of changing my password priviledges..
    I will anyway have a look at what you suggested and report back.
    thanks again

    CHMOD is rights to folders. It could be that for some reason certain folders or files are not writable (or even readable), that usually results in in the error that you gave. When I make the /wp-admin folder not writable and I have a plugin that needs to put a file in that folder, that’s the error that I get.

    As for the other thing, could it be that your admin information now is in the new tables, but you referred everything back to the old? Do you have two admin accounts in the database now?

    Just thinking out loud.


    so, thanks again Roy.
    I went through the steps of the sticky suggestion but didn’t help.
    what i did find out tho is that there are two users in my blog, one is admin (and is only one) and the other is WordPress?
    does WP needs a user-login and password?
    i never change the status (writable or readable) to any of my folders, but that means nothing, i might go back now and check ’em all..

    does WP needs a user-login and password?

    No, you get an “admin” by default, but my guess is (like I said before) that you’ve got one user for the first installation and a user for the second installation. Are you trying to login with the “admin” or “WordPress” user? In you table you should be able to find the hash of the password of the other user (or you just change it (hashed of course) to another one) and try to login with that. Look here to (de)code the password.

    well i checked the files and folders in my FTP.
    they all have writable and readable permission for the owner.
    most give permission to read to groups and public (644) but one (wp-config)(640).
    all of the active plug-ins also give executable permission to groups and public (755).
    all of the folders have a numeric value of 755
    i am the only one who can write in any file or folder thou.

    oh, ok, i try that, thanks

    i tried to log in with the other user_login but didnt get thru.
    one interesting aspect in all of this is that hwenever i hit the dashboard bookmark it defaults on the “You do not have sufficient permissions to access this page.” message.
    which makes me think it might even be an issue with the firewall or something?
    nope, just tried to log-in with the firewall of, with both of the users listed in MyAdmin and still didnt get in

    i think i will go to sleep.
    just too jaded to make any more clever and sensible moves.
    i’ll be back at it tomorrow.
    4 days on i still dont have my blog back but i got it back online for everyone else, which is pretty impressive for someone who’s got no idea where from to start..

    now, it seems to work.
    The problems turned out to be related to the Mysql database.
    In the panicking days of the past week i tried pretty much everything (as you would when you got no idea where to start from).
    One of the things I’ve done while my Blog disappeared was to keep restoring the database from my host.
    This created several versions of the database within my phpMyadmin account.
    I learned since that the reason my blog was not the way I left it was because I had to re-select the theme I used as a starting point for my hacking (personalization), and the reason why when I got the look back I still didn’t had all of my postings back was because I had to tell wp-config where to find the Mysql files.
    The last thing I learned is that, for some reason, all of those versions i created of my database in phpMyadmin all came with different passwords.
    So after much trail-and-error I managed to match the right database to the right password to the right theme, in wordpress 2.6.

    Now, I read 5 days worth of forum’s help pages,tutorials,comments and queries, and one thing Ii learned is that this worked for me, but is not a blanket solution.
    As a matter of fact I reckon what I just did is not a solution at all, rather a makeshift patch. Probably now that I still have full access to all of the components I should keep going while I can, back-up everything and re-load the lot in a clean-cut, un-adulterated new platform.
    But i just want to go n have a stiff drink now really.
    So, thanks Gangleri, I noticed you help out lots of other lost souls out there, well done. thanks.

    Congratulations. That was a nice learning experience was it? Well, I just do what I can: thinking out loud. I’m far from being a pro, the only thing I can do is make a suggestion when I experienced something myself or just make suggestions as use you as a guinee-pig 🙂


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘upgraded to 2.6 and lost my rights as admin?’ is closed to new replies.