Support » Installing WordPress » Upgraded to 2.5, now pages don’t display…WTF?

  • Resolved c0y0te

    (@c0y0te)


    Upgrade to 2.5 went ahead no problems, then when I test out my site I noticed that all my ‘pages’ were not found (e..g no post matched criteria) when I clicked on them.

    I’ve confirmed that the content is still there; tried editing/saving the pages again to see if it would make a difference but it doesn’t.

    can someone please tell me how to get my pages displaying again in 2.5 please?

    I’ve also noticed that 2.5 is MUCH SLOWER than the previous 2.3.3 version. It’s taking ages to get anything to load.
    Help?!?

Viewing 15 replies - 1 through 15 (of 107 total)
  • runography

    (@runography)

    I was having this problem and found that I had to change the Custom Permalink Structure.

    Go to Settings->Permalinks

    Custom Structure was checked and I had it set to

    /%postname%

    I changed it to

    /index.php/%postname%

    This seemed to do the trick, not ideal as it has index.php in all the url, but better than just the post id. I haven’t a chance to figure out why it did the trick, but glad it did.

    ectoplasm

    (@ectoplasm)

    I have the same problem. The only way I can view the Pages is to use the default Permalink structure. Anything else returns a 404.

    c0y0te

    (@c0y0te)

    It’s definitely something to do with permalinks all right, but I can’t figure it out.

    I’ve tried reassigning the permalink and updating .htaccess etc. but in the end I’m just not good enough with all this stuff, so I’ll need some help from a more informed soul please.

    My permalink is currently “/index.php/%category%/%postname%” and I’m running a plugin entitled “Deans Permalink Migration” because my original permalink was different.

    When set this way I can see all posts, but not pages. If I change the permalink I can then see pages, but not posts.

    I would love for my entire site to just simply be “/%category%/%postname%” (e.g. no /index.php) but that’s never worked for some reason.

    Help?!?

    haochi

    (@haochi)

    You are running on IIS, which doesn’t support mod_rewrite.
    There are more info in the Codex, and it links to several workarounds.

    vwoning2

    (@vwoning2)

    I’ve encountered the same problem. When installing WP 2.5 all posts/pages except the index return a server default error 404. Only when adding /index.php into the Custom Structure do I see my pages.

    /index.php/%year%/%monthnum%/%day%/%postname%/

    I am not hosted on IIS, I am hosted on Apache. I have WordPress installed in a /wordpress/ folder. I have a mod rewrite .htaccess in my root folder to force a www extension and to protect indexless directories and I have pasted the WP .htaccess file into the /wordpress/ folder to enable my settings.

    While troubleshooting this I removed my root level .htaccess and (after dumping cache) tried to view pages without success. So I am reasonably confident I haven’t got a .htaccess conflict.

    I have 2.5 RC1 installed and working successfully on another site on the same server. That account has an even more heavily configured .htaccess file in root and there are no problems. I am going to upgrade it to 2.5 and see if it breaks. I’ll let you know.

    vwoning2

    (@vwoning2)

    OK, it’s NOT a WP bug, at least not that I can tell from my upgrade test.

    I have a single VPS account and I have two identically configured websites on it. WP2.5 is on both. Both blogs are in subfolders. On the one that works, it is in a subfolder called /notes/. On the one that’s broken, it is in a /wordpress/ subfolder. The .htaccess files are correctly configured for each.

    I’m stumped. There’s no reason why one should be different than the other. There are no plugins other than Akismet 1.4 active on either, these are fresh installs.

    To be fair, there may be some hidden problem with the account that is borked. I previously tried installing WP 2.3.3 on that account and got array appearing all over the site. I’ve never been able to get WP working on that account in 5 minutes.

    I’ve got better things to do with a Sunday afternoon. And yes, for each install I’ve nuked the database AND the db-user and started from a clean slate. Far from ideal, but so is a URL hack.

    Anyone else have this experience and find a fix that doesn’t involve a URL hack?

    man999

    (@man999)

    You need IIS Mod-Rewrite Pro to get rid of the index.php in your URLs. The tool is commercial, but it pays back.

    They also have a detailed step-by-step guide for setting up wordpress clean permalinks on IIS. It involves some tweaking, but it’s simple and works fine.

    http://www.micronovae.com/ModRewrite/articles/CleanPermalinksWordpress.html

    I have successfully tested this with WP 2.3.x and 2.2.x, so it’s interesting to see if it works with WP 2.5 too, if anybody tries it.

    vwoning2

    (@vwoning2)

    OK, I’ll fess up.

    I carefully removed my .htaccess files from the server, and examined my local .htaccess files. I had NOT uploaded the correct .htaccess file into the /wordpress/ folder on the borked site…

    Yeah, I know.

    unstandable

    (@unstandable)

    “I have the same problem. The only way I can view the Pages is to use the default Permalink structure. Anything else returns a 404.”

    Same thing here for all posts and pages. I switched to the default structure so now people can get to the posts, but it means that all links to my posts are now broken. Anyone know how to fix this?

    c0y0te

    (@c0y0te)

    OK – so my options are…

    1) restore to 2.3.3
    2) move to a linux hosted solution
    3) Use IIS/Windows but purchase some tool

    Given that my site was working perfectly (albeit with the /index.php in the URL) and I could access posts AND pages, why am I now forced to choose between the above?

    Is there a problem with WP2.5 or is the problem somewhere else? Why was it working fine in 2.3.3 but not 2.5?

    c0y0te

    (@c0y0te)

    One other piece of info… I did a test upgrade of 2.5 first on my test site (http://www.avalon5.com/wptest) and it worked fine, and displayes pages and posts fine.

    I did the same thing on my live site (http://www.avalon5.com) and now I can’t display any pages.

    I just don’t get it? Why does it work on one installation but not the other?

    I’m having the exact same problem, i’m on a windows host have no modrewrite but managed to work around that by using blogname/index.php/postname but now the pages don’t work in wordpress 2.5.

    It looks lik anyone on a windows host is going to have this problem so could someone please help or tell us what has changed in wp 2.5 that is causing this?

    once again help please

    404 error for pages happens also in Apache (2.2.8, Unix and 2.0.54 Linux) hosted sites. The key is /index.php/%postname%/ permalink structure that causes the error.

    So how do we fix this without breaking all the backlinks? And further – why is it necessary to change when it was all working fine under 2.3.3?

    This sounds very familiar to an issue that I’m having, but I’m not sure if you’ve got a completely blank page, or if you just don’t have any information on the pages. Unfortunately, I can’t figure out how my issue may have been related to permalinks. I’d like to think it’s as simple as fixing something related to that.

    Here’s a thread I started based on my issue. I dunno if it’s the same or not…

    http://wordpress.org/support/topic/165191?replies=1

Viewing 15 replies - 1 through 15 (of 107 total)
  • The topic ‘Upgraded to 2.5, now pages don’t display…WTF?’ is closed to new replies.