Support » Installing WordPress » Upgraded to 2.5, now can’t login to admin and have warnings

Viewing 4 replies - 1 through 4 (of 4 total)
  • It appears some of the files didn’t get uploaded/overwritten or are corrupt.
    I would just go through the upgrade process again as outlined here:
    http://codex.wordpress.org/Upgrading_WordPress
    paying particular attention to step 1.
    Or better:
    http://codex.wordpress.org/Upgrading_WordPress_Extended
    steps 7 &8.

    Thanks Samboll. I followed the instructions, but got this error message when I ran upgrade.php:

    Warning: require(/home/zachever/public_html/wp-includes/compat.php) [function.require]: failed to open stream: No such file or directory in /home/zachever/public_html/wp-settings.php on line 202

    Fatal error: require() [function.require]: Failed opening required ‘/home/zachever/public_html/wp-includes/compat.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/zachever/public_html/wp-settings.php on line 202

    Also, my site no longer appears online; I get the same error message as when I try to access wp-admin or run upgrade.php.

    Joni

    (@jonimueller)


    Did you just decide to start over, Zack? I can get to your blog now, but it’s a fresh install. 🙁

    Kinda, Joni. My hosting company switched installers (from Fantisco to simple Scripts). The suggested gutting the whole site, installing 2.5 via Simple Scripts, and then adding the backup of the old site’s database that I made yesterday morning before I made any changes to the sites.

    Through two hours of phone calls, we got the site to 2.5, but there’s still a problem. When I access the site or wp-admin page, I get this error:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/zachever/public_html/wp-includes/widgets.php on line 678

    Warning: Invalid argument supplied for foreach() in /home/zachever/public_html/wp-includes/widgets.php on line 678

    Warning: Cannot modify header information – headers already sent by (output started at /home/zachever/public_html/wp-includes/widgets.php:678) in /home/zachever/public_html/wp-includes/pluggable.php on line 694

    The Blue Host Level II rep said installing the plugins that I had previously should fix the problem. But without access to the backend, I have no idea how to do so.

    He also said “You installed it without using the wp_ prefix for the database, which was used by your former database.” But I had to ask for clarification about what that means. Argh!

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upgraded to 2.5, now can’t login to admin and have warnings’ is closed to new replies.