Support » Fixing WordPress » Upgraded to 2.3 Posts do not appear

  • Hi all,
    I am supposed to be on vacation in Thailand. I am in Thailand, but this has not been much of a vacation so far…

    OK so we upgraded our blog to 2.3. on the surface everything appears fine but whenever I try to write a post – it just takes me back to the “write a post” page and no posts have been written. Help!

Viewing 15 replies - 1 through 15 (of 16 total)
  • I had a similar problem because TinyMCE was being a pain, and I kept getting either DB errors or being brought back to the Write Post page.

    I’d recommend clearing out your cache + cookies (e.g. Tools -> Clear Private Data in Firefox) and trying again.

    Your blog is trying to get you to go see a ping-pong show instead of blogging 🙂

    ps: never sit in the middle at those shows.

    (I’d offer something useful if I had it, but it sounds like Metlin has it covered)

    Sigh. I thought that was too good to be true Metlin. I cleared all my cache. And I am still being brought back to the Write Post page. Grrrr. Any other ideas? All my plugins are turned off too btw.

    Ping Pong show? Ivovic I love ping pong! I mean I haven’t played it much since my parents got rid of the table in the basement… So is a ping pong show something where the audience gets wowed by amazing feats of ping pong skills?

    Sounds like more fun than fixing blogs thats for sure…

    Oh god there’s a Gecko lizard on my monitor…

    So is a ping pong show something where the audience gets wowed by amazing feats of ping pong skills?

    … yes, but perhaps you should ask around first to make sure it’s what you expect 🙂

    I’m at a loss to explain your ‘white page’ problem unfortunately. It seems quite odd. Have you tried re-uploading all the wordpress files over the top of the existing files there?.. in case one of them has become corrupted or something?

    It seems more like an anomaly rather than a documented issue.

    Also, is your internet connection there a decent one, or is there a long time between submit and ‘white page’? – if so, your post could simply be timing out on the server side.

    It’s not a white page – I write a post, submit it and I am brought back to the Write Post page and the post disappears.

    Now I recently had to disable magic quotes in the .htaccess file because it was messing up all the code – for instance if I wrote the word “don’t” in a post it would render as “don/’t” It would do the same to image tags etc. – anything with code that PHP precedes with a trailing slash. Turning magic quotes off took care of the problem. I suspect it’s a server issue but the error logs are not proving to be helpful.

    Anyone have any ideas that DON’T involve ping pong shows which I just found out about Ivovic. No, I am not going. At least not until I fix this problem…

    Jewlicious –

    Does this happen only for posts or does this happen for pages, as well?

    Exact same thing happens for pages.

    Come on I can’t possibly be the only person in the entire world with this problem, can I? No not the Thai ping pong show thing, but the posts and the pages that do not appear. I will try to have more details later….

    ok here’s something – new posts/pages don’t write to the database. But I can create a new category without a problem. Does that help?

    What I would do is go to your YOURBLOGURL/wp-admin/upgrade.php and make sure the tables were upgraded. Then, if that doesn’t do the trick, go to your back-ups, then try the upgrade again. (I am assuming you didn’t do a big jump when upgrading.)

    Have you checked your web server’s error logs?

    I get this weird error:
    [client] script ‘/var/www/vhosts/’ not found or unable to stat

    this may have something to do with the fact that there used to be an instance of postnuke on the site and spammers are still trying to get to it. But in any case, all WP blogs, and there are several, on the server are making the same error.

    On another site on the same server, no errors at all are generated…

    CyberCore: The inability to write posts or pages happens on several blogs – some which have been upgraded and some that haven’t. I think it’s a server configuration issue.

    The one thing they all have in common is the .htaccess file which is as follows:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Another blog, same problem has only this in the .htaccess file:

    php_flag magic_quotes_gpc On

    Might this have something to do with it? I also just created a new blog without an .htaccess file on the same server and it works perfectly. What the heck…

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /YOURBLOGSMAINFOLDER/index.php [L]

    # END WordPress


    Try adding the dir to yours and see if that works.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Upgraded to 2.3 Posts do not appear’ is closed to new replies.