Support » Fixing WordPress » Upgraded to 2.2 and Lost my Sidebar

  • Resolved tjoyohboy


    Okay, I upgraded to version 2.2 through my hosting company (Dreamhost). So it was automatic. A few clicks and boom, I’m done.

    However, I lost my sidebar when I decided to edit it from the Dashboard. I clicked on the “Update File” button and when I got the “File successfully updated” message, all that remained in the sidebar.php file was a bunch of question marks.

    I checked my blog and the sidebar is gone!

    Thankfully, Dreamhost backed up the previous version of my blog. So I have the code.

    I tried copying and pasting the “old” code into sidebar.php (through Dashboard) and it didn’t work.

    I tried copying and pasting in the code into sidebar.php through FTP. Still didn’t work.

    So now I have a sidebar.php file that is empty, the file size from my FTP says 0 kb, and I have no idea what to do to fix this.

    Can anyone help?

    Thanks so much in advance!

    BTW, my blog URL is

Viewing 4 replies - 1 through 4 (of 4 total)
  • One more thing to add… my sidebar isn’t pushed down. It’s just gone.


    I found another post with the same problem. His issue was resolved because it was Dreamhost’s issue, not WordPress. I’ve contacted Dreamhost, and they can’t find anything that could be the problem on their end.

    Please, please, please help.

    I’ve switched themes and every time I try to edit the sidebar, no matter what theme I use, the code keeps disappearing. If you look at my page currently, there is a sidebar, because I switched to the theme and have not done anything to it.

    I’ve posted the code that I originally had in my sidebar *before* upgrading.

    Sorry if this is too long. I just want to get this resoved.


    [Moderated: Code removed. WAY too much. Either put it in a txt file and link to it, or use a pastebin service such as ]

    I went back to my original theme so you can see how it currently is.

    Last *bump* before I roll back to 2.1…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upgraded to 2.2 and Lost my Sidebar’ is closed to new replies.