Support » Plugin: Avatar Privacy » Upgraded to 2.3 and….

  • Resolved seanking2919

    (@seanking2919)


    For some reason, I got a blank screen immediately trying to load my site again after upgrading to 2.3.0.

    • This topic was modified 2 months, 1 week ago by seanking2919.
    • This topic was modified 2 months, 1 week ago by seanking2919.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Here’s the debug code given:

    Fatal error: Uncaught Error: Call to undefined function register_block_type() in /var/www/html/wp-content/plugins/avatar-privacy/includes/avatar-privacy/components/class-block-editor.php:99
    Stack trace:
    #0 /var/www/html/wp-includes/class-wp-hook.php(286): Avatar_Privacy\Components\Block_Editor->register_blocks(”)
    #1 /var/www/html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #2 /var/www/html/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #3 /var/www/html/wp-settings.php(456): do_action(‘init’)
    #4 /var/www/html/wp-config.php(118): require_once(‘/var/www/html/w…’)
    #5 /var/www/html/wp-load.php(37): require_once(‘/var/www/html/w…’)
    #6 /var/www/html/wp-admin/admin.php(31): require_once(‘/var/www/html/w…’)
    #7 /var/www/html/wp-admin/index.php(10): require_once(‘/var/www/html/w…’)
    #8 {main}
    thrown in /var/www/html/wp-content/plugins/avatar-privacy/includes/avatar-privacy/components/class-block-editor.php on line 99

    Plugin Author pepe

    (@pputzer)

    Oh. Sorry. That’s Gutenberg. Apparently I forgot to check for the existence of the functions when last-minute changing requirements back to 4.9 instead of 5.2 🙁

    Plugin Author pepe

    (@pputzer)

    I’ve just released 2.3.1 to fix the issue, @seanking2919.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.