WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » [W3 Total Cache] Upgraded to 0.9.2 – BROKEN in Firefox 4.0.1 and IE 9

[W3 Total Cache] Upgraded to 0.9.2 – BROKEN in Firefox 4.0.1 and IE 9

  • I was testing a brand new install on my development Blog of the prior version of 0.9.13 and everything was working great.

    THEN I upgraded and that broke Firefox 4.0.1 and IE 9. Ive turned off the Mobil Theme plug in and deleted the tables for same and checked my DB. No luck. Iv’e also turned off all the Browser Cache options except gzip and still no luck. Iv’e also played with the User Agent theme settings and no luck.

    This is certainly a “show stopper” and I hate to say that. Did I miss anything?

    SEE for yourself using Firefox 4.0.1 or IE 9 at:

    http://www.g17.com which is a test/development blog. 🙂

    It looks like a Mobil theme but NONE are installed or even in the DB.

Viewing 15 replies - 1 through 15 (of 47 total)
  • sorry…The thread title should have said:

    w3 total Cache

    I have the same problem on my site. I just updated and it’s doing the same thing for me.
    It seems the minify is broken. The minified .css and .js files are bad…

    “http://www.g17.com/wp-content/w3tc/min/c107d60f7f8096b68f1295ea893bcfbf.1437762405.css” contains this:
    “Bad file param format.”

    I’m getting the same error for the minifed files.

    You can disable auto-minifying in settings.

    The minify wizard is also unusable in FF4.0.1

    rryyaanndd

    🙂 Fantastic catch. I left Minify enabled so the developer can see it but turning it off is the fix as you pointed out.

    Also broken in Safari for the iPhone 3gs – latest os and browser.

    Can’t test in IE 8 yet but I’m sure it’s broken.

    HOW do I reach the developer directly? I would like to provide a heads up since minify is enabled by default. Hope you saved the previous versions zip?

    Same problems as mentioned above with minify,

    Also getting wrong charsets in different browsers.
    Using UTF-8 as standard:
    In firefox it loads with UTF-8
    Chrome us-ascii

    Disabling the plugin makes the charset load correctly.

    /Daniel

    OK, I uninstalled and deleated from my site and also sent the developer a contact us form submission. We have plenty of evidence 🙂 from experienced WP GEEKS 🙂

    You can get older versions of the plugin here:
    http://wordpress.org/extend/plugins/w3-total-cache/download/

    I had to disable minify settings to get my theme working for the moment. Really a show stopper 🙁

    Same here. Disabled Minify – it was fine in Chrome, but FF and IE were totally broken. Only weird thing is that I still DON’T see the “unminified” css files when I try to load the site on Pingdom Tools.

    This is most likely a user configuration issue. While auto-minify might work for some people, if you’re running many plugins and/or lots of JS files that are potentially written improperly, you could possibly break something leading to problems with the site loading properly.

    To alleviate this try switching to minify to manual and using the Help function to “help” find all of your JS and CSS files. Add all of them, making sure to take care in deciding where to add the JS files and what blocking to use. If you’re unsure try adding them to the section (head or end of body) that they are already located at in your code and use blocking.

    For the first round of testing do not use any of the advanced check boxes for the JS settings.

    If after adding all of the JS files and CSS without any advanced features you can try to enable comment removal and line space removal if you like.

    If either of these rounds of settings breaks your site, try only adding one JS file at a time. Once one JS file has been added and you have tested it on your site add another and test again. Do this until you find the file(s) that are not working when minified. You can then try to run them through JSlint to find errors or contact whoever developed the files to help with fixing them. If you are unable to fix a file that is not working while minified then don’t minify that file. You can select as few or as many files to combine and minify as you like.

    W3TC is an advanced plugin that requires time, experience, and tweaking in order to use it properly. I am personally running the development plugin on WP 3.1 Multi-site with about 10 sites. It works fantastically with no major issues.

    This issue started with our site on updating the plugin today as well. I do understand the issues listed, but nothing I did fixed any of them. To keep our site live after the update I had to deactivate the plugin.

    For —> kfawcett

    Respectfully, I appreciate your tips and myself and others are hardly what you would call plugin newbies, including but not limited to every major caching plugin available. 🙂

    Having said this, YOU MISSED the point which is all about default settings. PERIOD. Install and activate. Don’t touch a setting and see how it works.

    –> The prior version 0.9.13 worked great out of the box. PERIOD.

    —> The latest version 0.9.2 is BROKEN out of the box. PERIOD.

    Whatever options you turn on via a default install/activate need to be rock solid and work accross the majority of sites. Unfortunetly, thats NOT the case and although I’m not really a coder, first iompressions are everything.

    I would respectfully suggest that if you can’t fix the code then you turn the “minify” options all OFF for a default install and then warn the user. Since they all worked in the prior version perhaps more testing and help accross your user base would be inorder.

    Good luck 🙂

    Same here – CSS completely broken after the upgrade to 0.9.2. Disabling minify wouldn’t get it back (source showed the minify link still being inserted) Finally had to disable the plugin after having used it for quite some time. Will try disabling gzip compression as noted in another thread to see if I can at least get the plugin half working again…

    Interesting. I disabled the plugin entirely – ensured htaccess was clean. Re-enabled the plugin and ensured Minify was disabled – now things are working again. Disabling minify before didn’t work. I had to cycle the plugin. Now it seems OK without Minify (and gzip compression is enabled along with General, Browser, DB, and Object caches enabled)

    Fingers crossed – went a number of hours with no CSS – whoops!

    @desertgeek Sorry I should of read more.

    So I was thinking *whats the big deal* and I upgraded my W3TC and I bricked my server. I’m getting 500 errors. I guess there is something to everyone posting on here. 🙂

    I do have these two warnings in my logs.

    [Tue May 10 01:08:33 2011] [warn] mod_fcgid: stderr: PHP Warning: Invalid argument supplied for foreach() in /wp-content/plugins/w3-total-cache/lib/W3/Plugin/Minify.php on line 393

    preg_match() expects parameter 2 to be string, array given in //wp-content/plugins/w3-total-cache/inc/define.php on line 323

Viewing 15 replies - 1 through 15 (of 47 total)
  • The topic ‘[W3 Total Cache] Upgraded to 0.9.2 – BROKEN in Firefox 4.0.1 and IE 9’ is closed to new replies.
Skip to toolbar