Support » Theme: Spun » Upgraded Spun theme, now child theme not working

  • rachellucie

    (@rachellucie)


    Hi there,

    I have the Spun theme and finally bit the bullet tonight, by updating it to the latest version 2.0.2. I previously had a working child theme, but since updating Spun and making the child theme active again, nothing from the child theme works.

    I had fully expected that some of the workarounds for things in the child theme would now be irrelevant because of changes to Spun itself, and some funky effects to work through, but actually, the child theme might as well not be active at all.

    Any ideas why not?
    Here is my top code:

    /*
    Theme Name:     Spun Child
    Theme URI:      http://gallery.rachellucie.co.uk
    Description:    Child theme for the Spun theme
    Author:         Rachel Johns
    Author URI:     http://www.rachellucie.co.uk/
    Template:       spun
    Version:        2.0.2
    */
    
    @import url("../spun/style.css");

Viewing 13 replies - 1 through 13 (of 13 total)
  • rachellucie

    (@rachellucie)

    Any ideas on this one?
    (I’m not just bumping it – for some reason I can only find it from my profile, and wanted to check if this post is visible)

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    rachellucie

    (@rachellucie)

    Hi Andrew, the link is the ‘theme uri’ that you can see in the child header above 🙂

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Do you have a caching plugin?

    rachellucie

    (@rachellucie)

    no, unless that is something included in jetpack?

    rachellucie

    (@rachellucie)

    there is ‘vault press’ included – but I don’t have that activated.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Dont know

    What happens if you add this line:

    body { border: 10px solid red !important }

    Under this line:

    @import url("../spun/style.css");

    rachellucie

    (@rachellucie)

    ah, that certainly worked, so the child theme is working. Do you need to see the code in the rest of the child theme?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    The Child Theme style.css file is visible on your site already

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    What specifically isn’t working?

    rachellucie

    (@rachellucie)

    I had lots of tweaks to change colours, fonts, opacities of the menus, text styles etc. Basically since I upgraded and reinstalled the child theme, nothing I have added in the child theme works now. Although, added that red box code at the top did.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Can you give an example of some code that’s not working?

    rachellucie

    (@rachellucie)

    Hi Andrew,

    I didn’t come back to you because I found that there was some partially missing code in the child theme (not sure how I managed that). So, where I’m at is re-adding code as I find a need to a new child theme. Some of the things that I was overriding are different anyway with the new version of spun. I will post back if I get specific problems as they arise.

    Thanks for your help 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Upgraded Spun theme, now child theme not working’ is closed to new replies.