Support » Plugin: Google Analytics Dashboard » Upgraded, site dies with message "Please open this page in the Admin panel only"

Viewing 15 replies - 1 through 15 (of 19 total)
  • Yep. That broke WP all right. a temporary fix is to use cpanel file manager and edit the file:

    wp-content/plugins/google-analytics-dashboard/gad-admin-options.php

    Find line 34:

    die( "Please open this page in the Admin panel only." );

    and comment it out (thus killing that function):

    //die( "Please open this page in the Admin panel only." );

    nice Statement, WillOfTheWeb. Sadly made me laugh.
    Thanks for the temporary fix Cotswold.

    Please Guys, mark the Plugin as broken, if it kills your site!

    That fixes it for me.

    Same problem here. CotswoldPhoto fix solved the problem. Great. Thx.

    I can’t access the files in my wp-content folder, and I don’t have phpMyAdmin set up. Any other ideas on how to access my dashboard?

    tarheerlcrs: just open that file in your wp backend with > plugins > editor.

    This plugin uses deprecated (as in do not use any longer) functions that have been that way since WP 2.0. I see Yoost is listed as one of the team, so hopefully he either gets in there and fixes things or remove it from the repository. Abandoned plugins suck.

    Knocked out a couple of sites.

    Thanks for the fix CotswoldPhoto

    This isnt an abandoned plugin as it was just updated!!

    Last Updated: 2014-7-28

    For me I wasnt able to login to the backend. What I did was used CuteFTP and edited the file that way.

    I am a little disappointed that there hasn’t been any update from the authors about this big problem.

    I had this on a huge number of sites I managed and all went down! I had no option but to remove the plugin completely.

    WordPress 2.0 came out in 2005. This plugin still uses functions from that far back. I would avoid a plugin using that old of code. I would consider that abandoned.

    This is the notice you will get if you have debugging turned on:
    “Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.”

    Thanks for the fixing instructions – this error is real bad karma though, please get to it asap…

    This is fixed in version 2.1.1, so please update the plugin to the latest version.

    Now the plugin has disappeared!

    Whoops!

    We couldn’t find that plugin.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Upgraded, site dies with message "Please open this page in the Admin panel only"’ is closed to new replies.